Выпущено обновление SMF 2.0.15

Автор digger®, 20 Ноябрь 2017, 12:58:26

« назад - далее »

0 Пользователей и 1 гость просматривают эту тему.

digger®

Проект Simple Machines Forum выпустил обновление для 2.0.x. Текущей версией становится SMF 2.0.15.

Это обновление исправляет уязвимости и ошибки и добавляет некоторые улучшения, поэтому рекомендуется своевременное обновление.

Краткий список изменений:
  • Исправление уязвимости выявленной Daniel Le Gall from SCRT SA
  • Исправления в прокси изображений
  • Исправления входа в режиме обслуживания и SSI
  • Исправления в поиске
  • Исправление обработки электронной почты при использовании SendTopic
  • Исправление в сборе статистики SMF и добавление возможности включения/выключения ее в админке

Список изменений:
Код
SMF 2.0.15                                                    November 19, 2017
===============================================================================

September 2017
 ! Fixed a minor $smcFunc bug in Search-Fulltext.php
 ! Fixed a saving Settings.php bools being reset bug
 ! Fixed a security issue (Reported by Daniel Le Gall from SCRT SA)

June 2017
-------------------------------------------------------------------------------
 ! Cache the admin search results in the session and avoid IE's 2083 character limit
 ! Fixed a Mark Board Read bug

May 2017
-------------------------------------------------------------------------------
 ! Fixed Proxy URLs not handling redirects properly due to case sensitivity
 ! Fixed SendTopic using incorrect Post data
 ! Fixed SSI.php having a bad login panel
 ! Fixed Maintenance Page having a double login button
 ! Fixed a minor unsigned int typo in MySQL DB
 ! Fixed Deprecated installer message for ftp_connection.
 ! Fixed a loop bug in custom search
 ! Fixed SM Stat collection
 ! Added SM Stat collection registration to the Admin Control Panel

SMF 2.0.14 можно обновить используя менеджер пакетов. Вы должны увидеть уведомление об обновлении в панели администратора и менеджере пакетов, что позволяет легко загрузить и установить обновление. Если у вас нет уведомления об обновлении, запустите запланированное задание "Получение файлов с сайта Simple Machines" в диспетчере задач. Вы, также, можете вручную скачать пакет обновления со страницы загрузок официального сайта, и установить его с помощью менеджера пакетов.

Если вы используете старые версии SMF, то можете обновиться с помощью полного пакета обновления со страницы загрузок официального сайта. Помните, что использование этого метода обновления потребует переустановки всех установленных на форуме модов.

Если у вас возникли проблемы с загрузкой обновления из панели администратора, вы можете загрузить пакет со страницы пакетов обновлений и установить его как обычный мод.

Более подробную информацию можно получить в Справочных руководствах:
* Полное обновление  
* Пакетное обновление

Для новых установок рекомендуется использовать локализованный дистрибутив https://github.com/realdigger/SMF-2.0-RU

Оригинал: https://www.simplemachines.org/community/index.php?topic=557176.0

Эта версия SMF требует PHP 5.4 или выше. Вы можете проверить свою версию в разделе "Поддержка и благодарности" в админке форума.

gorbi


valdnieks

Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

Liza

Интересно с 2.0.13 сразу на 2.0.15 не получится?

gorbi

Цитата: gorbi от 20 Ноябрь 2017, 17:15:12С пылу-жару не получилось
Сделаю попозже. Просто раньше всё ставилось влёт до 14-го релиза.  :'(

valdnieks

Цитата: Liza от 20 Ноябрь 2017, 17:33:34Интересно с 2.0.13 сразу на 2.0.15 не получится?

Нет. Здесь корректировка. В 2.0.13, например, нет прокси.
Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

S.T.A.L.K.E.R.

Цитата: Liza от 20 Ноябрь 2017, 17:33:34Интересно с 2.0.13 сразу на 2.0.15 не получится?
Нет,через 2.0.14

Как не странно ни одной ошибки при обновлении.С моими то изменениями....
Настройки сервера появился чекбокс позволить собирать статистику...
Пока наблюдаю.

Snow_Irbis

Подожду немного времени, а потом только буду обновляться, а то как вспомню предыдущее обновление 2.0.14 так аж волосы дыбом :facepalm:

ПИ Кстати кто знает серьезная та уязвимость о которой написано "Исправление уязвимости выявленной Daniel Le Gall from SCRT SA"?

gorbi

Цитата: Snow_Irbis от 20 Ноябрь 2017, 19:37:01Подожду немного времени, а потом только буду обновляться, а то как вспомню предыдущее обновление 2.0.14 так аж волосы дыбом
Во-во!

S.T.A.L.K.E.R.

Не знаю у кого как...Ошибок нет,проксирование работает как и должно работать.Обновление и работа пока в норме.ТТТ.

karavan

20 Ноябрь 2017, 22:43:09 #10 Последнее редактирование: 20 Ноябрь 2017, 23:04:46 от karavan
После обновления не могу войти в админку (обновление пришло без ошибок). Все остальное работает нормально, в том числе и ссылки на разделы админки типа /forum/index.php?action=admin;area=packages

Не работает главный вход в админку:
http://****/forum/index.php?action=admin
Fatal error: Function name must be a string in /home/****/******/www/forum/Sources/Subs-Admin.php on line 80

digger®

Цитата: karavan от 20 Ноябрь 2017, 22:43:09После обновления не могу войти в админку (обновление пришло без ошибок). Все остальное работает нормально, в том числе и ссылки на разделы админки типа /forum/index.php?action=admin;area=packages

Не работает главный вход в админку:
http://****/forum/index.php?action=admin
Fatal error: Function name must be a string in /home/****/******/www/forum/Sources/Subs-Admin.php on line 80
Мод MySQLi случайно не установлен?

valdnieks

Цитата: digger® от 20 Ноябрь 2017, 12:58:26
  • Исправления в поиске

Ошибки как были, так и осталось.
----
Ярлык, думаю отобразится - нет.  :facepalm:

https://github.com/realdigger/SMF-Top-First-Post
Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

karavan

Цитата: digger® от 20 Ноябрь 2017, 23:12:29Мод MySQLi случайно не установлен?
Да, действительно установлен.


karavan

Да, действительно помогло, спасибо. O0

Oleg+

Цитата: digger® от 22 Ноябрь 2017, 16:01:54Удаление поможет, скорее всего.
У меня та же ошибка и тоже установлен этот мод.

Вопрос : можно ли решить проблему без удаления этого мода?
Житель района Восточное Дегунино (Москва, Россия)

digger®

Цитата: Oleg+ от 23 Ноябрь 2017, 09:57:35У меня та же ошибка и тоже установлен этот мод.

Вопрос : можно ли решить проблему без удаления этого мода?
MySQLi поддерживается в последних версиях SMF. Мод не нужен.

GeorG

Цитата: Oleg+ от 23 Ноябрь 2017, 09:57:35Вопрос : можно ли решить проблему без удаления этого мода?
А зачем вам этот мод, все же присутствует в патче 2.0.14?
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

karavan

Возможно ощущение субъективное, но мне кажется, что форум стал работать быстрее после удаления этого мода.

valdnieks

Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

Сан

Поставил 2.0.15 с нуля без модов, только rus-utf8.
В админке задаю добавочное поле профиля.
Первое поле создаётся, а следующее - нет.
Пишет:
Duplicate entry 'cust_' for key 'col_name'
Файл: F:\OpenServer\domains\pensionik\Sources\ManageSettings.php
Строка: 1868
Сравнил эту строку и рядом другие 2.0.15 и 2.0.14 - одинаково.
Если не трудно, кто-нибудь посмотрите, у вас также?


GeorG

Если не ошибаюсь, была ошибка какая-то, если для первого поля задать название на русском (кириллице). Думал исправили уже.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

Сан

Сейчас перепроверил и на 2.0.15 и на 2.0.14  без каких-либо дополнений и без русификатора на ОпенСервер одинаково ругается.
А если создать на аглицком, а потом отредактировать по-русски, то работает.
В базе посмотрел, там присваивается очерёдность cust_, cust_1, cust_2 и т. д.
Где-то цифирька видно  теряется при создании очередного поля.
Узнать бы место, но это не по моим знаниям.

GeorG

Цитата: Сан от 25 Ноябрь 2017, 19:03:39В базе посмотрел, там присваивается очерёдность cust_, cust_1, cust_2 и т. д.
Возможно если название первое на кириллице то цифра не присваивается, от того дубль получается (это как вариант, я не смотрел).

Цитата: Сан от 25 Ноябрь 2017, 19:03:39А если создать на аглицком, а потом отредактировать по-русски, то работает.
Потом можно уже сразу давать на русском названия, ошибки больше быть не должно.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

S.T.A.L.K.E.R.

Если очистить кеш форума,потом в папке форума кеш вычистить все сохраненные там проксированные изображения.Потом через Ctrl+F5 обновляем страницу на которой есть проксированные изображения.Они не отображаются,вместо них пустота.Потом обновляю страницу,все проксированные изображения появляются.Я поначалу грешил на последние изменения на форуме после установки мода.Но у меня сохранился бекапом старый файл proxy который я вручную правил по найденым советам с оф.форума,я его подменил и всё стало нормально отображаться.У кого то ещё есть подобное?

GeorG

Тоже самое, если открывать первый раз сообщение где есть непроксированное изображение (или смотреть через предварительный просмотр), то отображается изображение, только на второй раз. Но я как-то не заострял на этом внимание.

Цитата: S.T.A.L.K.E.R. от 02 Декабрь 2017, 20:04:38я вручную правил по найденым советам с оф.форума
Есть ссылка на эти советы? Да и на сам рабочий файл, было бы любопытно взглянуть. :)
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

S.T.A.L.K.E.R.

Цитата: GeorG от 03 Декабрь 2017, 10:54:11Тоже самое, если открывать первый раз сообщение где есть непроксированное изображение (или смотреть через предварительный просмотр), то отображается изображение, только на второй раз. Но я как-то не заострял на этом внимание.
Я вчера тестовый ставил,и проверял уже поздно ночью.То же самое.
Значит так до конца и не доделали.Где правки я брал я уже и не помню,или с 2.1 брал - там расхождения небольшие есть.Но работает,во вложении.
Надо наверно на оф писать,никто не в курсе - там о таком никто не отписывался ещё?

Ram

03 Декабрь 2017, 13:15:14 #28 Последнее редактирование: 03 Декабрь 2017, 13:25:39 от Ram
Подскажите .

Пытаюсь обновить форум  с 2.0.13 на 2.0.14

Выскакивает

Fatal error: Function name must be a string in /var/www/u****            /Sources/Load.php on line 142

Ещё летом пытался обновить , такая же ошибка была , думал исправили может быть.

Хостинг рег точка ру.

Версия Apache 2.4.29
Версия PHP 5.4.45
Версия MySQL 5.6.35-81.0
Версия Perl 5.10.1

Как тут быть ? Можно ли сразу установить полную версию апгрейда ?

valdnieks

Был разговор, что на версии пхп ниже 5.5 не будет работать.
Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

Ram

Цитата: valdnieks от 03 Декабрь 2017, 13:33:18Был разговор, что на версии пхп ниже 5.5 не будет работать.

Да я помню тему

https://www.simplemachines.ru/index.php?topic=19909.150

С тех пор ничего не изменилось ?  Сразу 2.015 нельзя поставить поверх  2,013 ?

S.T.A.L.K.E.R.

Должен он работать на 5.4.Обновлять нужно последовательно.
А что в самой строке и в ближайших на которые он ругается?

Ram

Цитата: S.T.A.L.K.E.R. от 03 Декабрь 2017, 13:48:57Должен он работать на 5.4.Обновлять нужно последовательно.
А что в самой строке и в ближайших на которые он ругается?

В 142 строках вот на картинке  https://yadi.sk/d/bunI78723QGTkj


S.T.A.L.K.E.R.

Не пробывали очистить кеш форума перед обновлением.И вычистить заодно все логи,пауков и всего остального в том числе.

Ram

Цитата: S.T.A.L.K.E.R. от 03 Декабрь 2017, 14:14:51Не пробывали очистить кеш форума перед обновлением.И вычистить заодно все логи,пауков и всего остального в том числе.
Летом  пробовал после ошибок обновления
пс. путаю , да вроде пробовал

Такой вопрос , в обновлении 2,014 и 15 есть какие критические уязвимости ? Так ли стоит переходить на 15 ?

S.T.A.L.K.E.R.

Цитата: Ram от 03 Декабрь 2017, 14:20:23в обновлении 2,014 и 15 есть какие критические уязвимости ? Так ли стоит переходить на 15 ?
В 2.0.14 прикрутили проксирование изображений для форумов работающих с SSL сертификатами.В 2.0.15 типо пофиксили все ошибки в прксировании изображений в версии 2.0.14.Почему типо - так уже нашлись ещё ошибки.Чую скоро будет 2.0.16 :)

Ram

Цитата: S.T.A.L.K.E.R. от 03 Декабрь 2017, 14:32:37В 2.0.14 прикрутили проксирование изображений для форумов работающих с SSL сертификатами.В 2.0.15 типо пофиксили все ошибки в прксировании изображений в версии 2.0.14.Почему типо - так уже нашлись ещё ошибки.Чую скоро будет 2.0.16 :)

Спасибо . Тогда не буду замарачиваться пока.  А там может на хостинге поменяется что и всё заработает .

S.T.A.L.K.E.R.

03 Декабрь 2017, 18:58:43 #37 Последнее редактирование: 03 Декабрь 2017, 21:08:09 от S.T.A.L.K.E.R.
Цитата: GeorG от 03 Декабрь 2017, 10:54:11Есть ссылка на эти советы? Да и на сам рабочий файл, было бы любопытно взглянуть.
Извиняюсь,вот
Если что фикс тут - https://www.simplemachines.org/community/index.php?topic=557511.new#new - напомнили
Кстати в SMF 2.1 Beta 3 тот же косяк.

S.T.A.L.K.E.R.

Единственное пожелание к разработчикам которое думаю нужно оформить - это добавить в диспетчер задач задачу чистить папку кешированных изображений по настраиваемой задаче.Пока приходится выкручиваться кроном.Хотя и им прелестно чистит.Просто мне не нужно хранить в кеше прям уж все сторонние картинки.В добавок что они и так повторно создадутся если кто-то зайдет на страницу с ними.
Чего так изначально не было сделать ума не приложу.Хотя может кто-то и мод такой сделает.

ezheck

Русская локализация в 2.0.15 определяется как 2.0.12, собственно говоря это она и есть вроде.
C download.simplemachines.org cкачать можно только 2.0.15, версию 2.0.14 же не скачать.
Что делать то?

S.T.A.L.K.E.R.

Цитата: ezheck от 26 Октябрь 2018, 22:34:55Русская локализация в 2.0.15 определяется как 2.0.12, собственно говоря это она и есть вроде.
C download.simplemachines.org cкачать можно только 2.0.15, версию 2.0.14 же не скачать.
Что делать то?
Ничего.Забить  и забыть.
Это никак не влияет на работу движка.
Это локализация языковая и не более.На работу движка она влияния не имеет никакого.

Сан

ezheck, на оф. сайте верхнее горизонтальное меню - найдите ссылку" Download"
Далее слева вертикальное меню - найдите ссылку "Archived Releases"
И тут можно скачать хоть самую первую двойку

Индиго Бой

Пару недель не заходил на свой форум а там оказывается сбилась кодировка в БД, что теперь делать, бекап месячный назад даже не помогает