Выпущено обновление SMF 2.0.14

Автор digger®, 15 Май 2017, 01:01:19

« назад - далее »

0 Пользователей и 1 гость просматривают эту тему.


Василич

Цитата: digger® от 26 Июль 2017, 17:16:05Если форум не на https, то незачем.

На https:// у меня ..... Так зачем?


Krivich26rus

Цитата: gorbi от 18 Июль 2017, 21:28:58Все моды заработали на семёрке?
Все, но  у меня их немного.

Krivich26rus

Подскажите, как исправить?
  wallbash

Обнова 2.0.14 установлена.

S.T.A.L.K.E.R.

Забить,ничего страшного.
Или если так принципиально в самом файле версию поправьте.

xoxma

После 4го шага на /install.php?step=5
502 Bad Gateway вываливается =(
Ставлю с нуля на поддомен(не должно влиять)эту версию SMF-2.0-RU-v2.0.14.2.
PHP 5.4.21, должно же встать норм, в чём косяк?

GeorG

Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

xoxma

Цитата: GeorG от 26 Сентябрь 2017, 21:20:44Последняя версия с исправлениями Диггера тут - https://github.com/realdigger/SMF-2.0-RU/releases/tag/v2.0.14.2
Тоже пробовал, та же проблема...
Стучу хостеру, чтобы поднял до 7 пхп, предлагают 7.1.
PHP 7.1 прокатит ли тоже?..

GeorG

27 Сентябрь 2017, 08:20:48 #159 Последнее редактирование: 27 Сентябрь 2017, 08:38:06 от GeorG
Сам форум версии 2.0.14 должен отлично работать и на версии php 5.4, на 7.1 скорее всего у вас будут большие проблемы с модами, если адаптировать их потом не сможете на эту версию php, то очень много модификаций у вас работать вообще не будет (адаптировать уже будете или сами, или ждать пока это сделает их автор, или какого-то нанимать на это дело).

Что в логах? От пятисотых ошибках, там всегда очень много интересного остается.

p.s. Вообще, у вас ошибка на почве подключения к БД или работы с ней, т.к., на 5 шаге заполняется база данных, а вот детали, только логи скажут.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

Василич

Цитата: GeorG от 27 Сентябрь 2017, 08:20:48Сам форум версии 2.0.14 должен отлично работать и на версии php 5.4, на 7.1 скорее всего у вас будут большие проблемы с модами, если адаптировать их потом не сможете на эту версию php, то очень много модификаций у вас работать вообще не будет (адаптировать уже будете или сами, или ждать пока это сделает их автор, или какого-то нанимать на это дело).

Что в логах? От пятисотых ошибках, там всегда очень много интересного остается.

p.s. Вообще, у вас ошибка на почве подключения к БД или работы с ней, т.к., на 5 шаге заполняется база данных, а вот детали, только логи скажут.

Вообщем , лишний раз убеждаюсь по жизни, что лучше - враг хорошего .... Работает и пусть работает ... И не дышать ....  ;D

Мэл

Подскажите пожалуйста, кто знает: форум на 2.0.13, при обновлении выскакивает ошибка в файле ./SSI.php. Если продолжать установку, сбивается кодировка и появляются крякозябры. Где копать?)

Версия MySQL: 5.6.36-cll-lve
PHP: 5.4.45
"Great spirits have often encountered violent opposition from weak minds" - Albert Einstein

GeorG

Цитата: Мэл от 12 Октябрь 2017, 12:45:18при обновлении выскакивает ошибка в файле ./SSI.php
Какая?

Цитата: Мэл от 12 Октябрь 2017, 12:45:18сбивается кодировка и появляются крякозябры. Где копать?
В сторону кодировки.

Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

Мэл

GeorG
Просто пишет "Неудачно" на этапе "Действия при установке пакета "SMF 2.0.14 Update", рекомендуя воздержаться от установки.
А что можно сделать с кодировкой?
Раньше все апдейты ставились как по маслу.
"Great spirits have often encountered violent opposition from weak minds" - Albert Einstein

valdnieks

Неудачно, значит не находит необходимую строку(и). Сделайте вставку вручную. Вначале откройте операцию, например:


Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

Мэл

О, вот даже как можно! Говорю же, не сталкивался ранее с ошибками :facepalm:

Там вот такое.
"Great spirits have often encountered violent opposition from weak minds" - Albert Einstein

valdnieks

Строка, мод которую пытается найти изменилась другим модом.
Найдите изменённую, например, с помощью notepad++
и вставьте строку с прокси:
global $image_proxy_enabled, $image_proxy_secret, $image_proxy_maxsize;
вручную.
Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

Мэл

"Great spirits have often encountered violent opposition from weak minds" - Albert Einstein

Мэл

Форум обновляется нормально, но проблема с кодировкой никуда не уходит :( Именно в названиях тем и сообщениях идут крякозябры типа ѕРјР°РЅРґРµ. Подскажите пожалуйста, кто знает, что можно сделать, как исправить кодировку?
"Great spirits have often encountered violent opposition from weak minds" - Albert Einstein

GeorG

У вас в БД если смотреть таблицу smf_messages (эта таблица с сообщениями) к примеру через phpmyadmin, там всё нормально, без крякозябликов отображается?

Изначально кодировка форума и БД, соответствуют друг другу?
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

Мэл

Да, в smf_messages все сообщения видны нормально.

Кодировка форума и БД соответствовать должна, но я не уверен... Как можно это проверить? У меня русский на форуме загружен в 1251 и в UTF-8, по-дефолту стоял второй.
"Great spirits have often encountered violent opposition from weak minds" - Albert Einstein

GeorG

Посмотрите в phpmyadmin в какой кодировке там таблицы, если форум в utf8, то и таблицы в БД должны быть в это же кодировке.

У вас после обновления, крякозяблики видны когда вы авторизованы на форуме и когда под гостем, или только когда авторизованы?
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

digger®

Цитата: Мэл от 12 Октябрь 2017, 12:45:18Подскажите пожалуйста, кто знает: форум на 2.0.13, при обновлении выскакивает ошибка в файле ./SSI.php. Если продолжать установку, сбивается кодировка и появляются крякозябры. Где копать?)

Версия MySQL: 5.6.36-cll-lve
PHP: 5.4.45
Это не про свклуб речь? Там php5.3 насколько я вижу в админке.

Мэл

Цитата: GeorG от 13 Октябрь 2017, 00:19:27Посмотрите в phpmyadmin в какой кодировке там таблицы, если форум в utf8, то и таблицы в БД должны быть в это же кодировке.
Все в cp1251_general_ci.
ЦитироватьУ вас после обновления, крякозяблики видны когда вы авторизованы на форуме и когда под гостем, или только когда авторизованы?
Крякозябры видны всем, и гостям, и залогиненным.
Цитата: digger® от 13 Октябрь 2017, 01:02:19Это не про свклуб речь? Там php5.3 насколько я вижу в админке.
Нет, его я не обновлял пока, тут другой форум.
"Great spirits have often encountered violent opposition from weak minds" - Albert Einstein

GeorG

Цитата: Мэл от 13 Октябрь 2017, 11:26:13Все в cp1251_general_ci.
Ну вот вам и причина, если вы пишете что сам форум настроен на работу с кодировкой в utf8, а БД в кодировке CP 1251, что вы ещё тогда хотели?

Приводите БД и форум к одной кодировке.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

Мэл

Цитата: GeorG от 13 Октябрь 2017, 12:53:07Ну вот вам и причина, если вы пишете что сам форум настроен на работу с кодировкой в utf8, а БД в кодировке CP 1251, что вы ещё тогда хотели?

Приводите БД и форум к одной кодировке.
Я в этом не очень хорошо разбираюсь, язык стоит в 1251, но крякозябры все равно присутствуют. Что мне ещё следует сделать, чтобы это исправить?
"Great spirits have often encountered violent opposition from weak minds" - Albert Einstein

GeorG

Посмотрите в какой кодировке у вас сам форум работает.
В админке, настройка языков, у вас там сейчас что?

Цитата: Мэл от 13 Октябрь 2017, 13:03:27Я в этом не очень хорошо разбираюсь
Если боитесь что-то испортить, и нужна помощь на платной основе, обращайтесь в ЛС.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

Мэл

Цитата: GeorG от 13 Октябрь 2017, 13:22:52Посмотрите в какой кодировке у вас сам форум работает.
В админке, настройка языков, у вас там сейчас что?
Там стоит у всех windows-1251 (локаль ru_RUCP1251), по-умолчанию тоже стоит он (не UTF-8).

За предложение спасибо, думаю я с виртуальной помощью сам разберусь, хочется довести дело до конца))
"Great spirits have often encountered violent opposition from weak minds" - Albert Einstein

valdnieks

Вы в каталоге languages делали какие-нибудь изменения (файлы)?
Notepad++ красиво всё показывает.
Были у меня парочка ошибок, просмотрел, подкорректировал и на форуме увидел больше.
Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

GeorG

Цитата: Мэл от 13 Октябрь 2017, 13:36:15Там стоит у всех windows-1251 (локаль ru_RUCP1251), по-умолчанию тоже стоит он (не UTF-8).
У вас это сейчас на рабочем форуме так (когда нет проблем с кодировкой), или это тогда, когда на форуме крякозяблики?
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

digger®

Цитата: Мэл от 13 Октябрь 2017, 13:36:15Там стоит у всех windows-1251 (локаль ru_RUCP1251), по-умолчанию тоже стоит он (не UTF-8).
Для SMF 2.0.14 минимальная версия php 5.4.
SMF на php 5.4 и старше не работает нормально с 1251, там в любом случае будет веер всяких проблем.

Мэл

Цитата: valdnieks от 13 Октябрь 2017, 14:08:12Вы в каталоге languages делали какие-нибудь изменения (файлы)?
Notepad++ красиво всё показывает.
Были у меня парочка ошибок, просмотрел, подкорректировал и на форуме увидел больше.
Нет, изменений не делал, единственное что стоит набор языков 1251 и UTF-8, но их файлы вроде как друг на друга не влияют.
К сожалению, Notepad++ на моей системе нет.
Цитата: GeorG от 13 Октябрь 2017, 14:38:20У вас это сейчас на рабочем форуме так (когда нет проблем с кодировкой), или это тогда, когда на форуме крякозяблики?
Сейчас, когда крякзоябры после обновления на 2.0.14 вылезли.
Цитата: digger® от 13 Октябрь 2017, 15:12:02Для SMF 2.0.14 минимальная версия php 5.4.
SMF на php 5.4 и старше не работает нормально с 1251, там в любом случае будет веер всяких проблем.
У меня на этом стоит:
Версия MySQL: 5.6.36-cll-lve
PHP: 5.4.45
Вроде должно работать...
"Great spirits have often encountered violent opposition from weak minds" - Albert Einstein

valdnieks

Цитата: digger® от 13 Октябрь 2017, 15:12:02SMF на php 5.4 и старше не работает нормально с 1251, там в любом случае будет веер всяких проблем.

У меня форум отлично работает. Есть маленькие неприятности, это не проблема. Всё можно решить, а хочется по-быстрее.
Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

valdnieks

Цитата: Мэл от 13 Октябрь 2017, 15:24:23Нет, изменений не делал, единственное что стоит набор языков 1251 и UTF-8, но их файлы вроде как друг на друга не влияют.

Конечно не влияют, в одних строках нормально, в других иероглифы, одним словом винегрет.

Цитата: Мэл от 13 Октябрь 2017, 15:24:23К сожалению, Notepad++ на моей системе нет.

У Вас какая ОС? У меня винда, кодировка cp1251. Редактирую в total commander.
Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

Мэл

valdnieks
Mac OS, использую редактор или Ворд.
"Great spirits have often encountered violent opposition from weak minds" - Albert Einstein

valdnieks

Tc up, не смотрел, может найдёте лучший дистрибутив:

https://cloud.mail.ru/public/3TdW/j8xWJJ8VM
Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

digger®

Цитата: Мэл от 13 Октябрь 2017, 15:24:23Нет, изменений не делал, единственное что стоит набор языков 1251 и UTF-8, но их файлы вроде как друг на друга не влияют.
К сожалению, Notepad++ на моей системе нет.Сейчас, когда крякзоябры после обновления на 2.0.14 вылезли.У меня на этом стоит:
Версия MySQL: 5.6.36-cll-lve
PHP: 5.4.45
Вроде должно работать...
В скайп напишите, посмотрю что там.

GeorG

Конвертировать БД в UTF8 надо, иначе ещё много сюрпризов может быть (разрабы тоже это рекомендуют).
Попробовать как вариант для php_value default_charset установить windows-1251.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

Серый Лис

Цитата: Мэл от 13 Октябрь 2017, 16:27:31Mac OS, использую редактор или Ворд.
Мэл   
Вы поступите мудрее, если воспользуетесь для правки кода в OS X редактором Adobe Dreamweaver CC 
Для операционной системы версии 10.12, либо OS X версий 10.11 или 10.10 можно взять   Тут 
А для  OS X версий 10.7, 10.8, или 10.9 взять   Здесь  


Мэл

digger®
Спасибо, чуть позже напишу, сейчас кое-как устранил крякозябры, в воскресенье думаю сесть за более вдумчивый разбор полетов.

GeorG
Да, сейчас крякозябры у меня пропали, но только при UTF-8 на форуме, соответственно действительно надо конвертировать БД в UTF-8. Где-то на этом форуме об этом уже читал, вроде бы сложностей возникнуть не должно...

Серый Лис
Премного благодарен! Так-то да, на ПК я привык к Notepad++.
"Great spirits have often encountered violent opposition from weak minds" - Albert Einstein