Coppermine отображение альбомов такими символами ???????????????

Автор gimber, 22 Ноябрь 2008, 11:40:13

« назад - далее »

0 Пользователей и 1 гость просматривают эту тему.

gimber

понимаю что форум по SMF! но может кто сталкивался! я везде уже спрашиваю :-[

Народ, поставил галерею, кодировка стоит UTF8 по дефолту, весь шрифт галереи отображается норм, создаю альбом с русским названием - отображается ???????????

Пробовал уже добавлять кодировку в админ.пхп!!!!!! (в шоке) добавил кирилицу вин 1251
стала вся галерея отображаться в иероглифах! в браузере кодировка стоит АВТОВЫБОР
как быть?! у меня подозрение такое:
база MySQL имеет другую кодировку и путает всё?
как быть чтобы альбомы отображались нормально????:(((((((

Stern

Цитата: gimber от 22 Ноябрь 2008, 11:40:13
понимаю что форум по SMF! но может кто сталкивался! я везде уже спрашиваю :-[
... у меня подозрение такое:
база MySQL имеет другую кодировку и путает всё?
как быть чтобы альбомы отображались нормально????:(((((((
Именно так.
кодировка баз прописывается в трёх-четырёх местах - надо всё проверять.
на сайте техподержки коппермайна вроде бы публиковалось решение аналогичной проблемы.
МышЫ плакали, кололись, но продолжали жрать кактус...

romeo

может кто подскажет , что нужно сделать?
а то аналогичная проблема... при создание альбомов и категорий на русском -- отображаются знаками вопроса??
искал на форуме копермайна -- не нашел...

Stern

Цитата: romeo от 06 Декабрь 2008, 00:39:02
может кто подскажет , что нужно сделать?
а то аналогичная проблема... при создание альбомов и категорий на русском -- отображаются знаками вопроса??
искал на форуме копермайна -- не нашел...
есть там. абсолютно точно.
какая версия Галереи?
МышЫ плакали, кололись, но продолжали жрать кактус...

romeo

Цитата: Stern от 14 Декабрь 2008, 18:00:45
есть там. абсолютно точно.
какая версия Галереи?
Coppermine Photo Gallery v1.4.19
форум в UTF-8 -- галерею ставил с интеграцией и тоже в UTF-8

MetallOFFON

Аналогичная проблема.
http://foto44.ru/gallery/index.php
Все языковые константы нормально отображаются.
Весь остальной русский текст - ?????????????


MetallOFFON

11 Январь 2009, 12:36:20 #7 Последнее редактирование: 11 Январь 2009, 13:06:56 от MetallOFFON
И как ее сделать utf8?
В настройках выбрал utf-8.

jeeper

Уважаемые, помогите советом. Стоит галерея 1.4.21, кодировка 1251 (http://www.__samarafishing.ru/cpg14x/index.php).
В Мозилле всё  отображается корректно, а IE и хром выдают квадратики. В "template.html" прописал кодировку жёстко ("<meta http-equiv="Content-Type" content="text/html; charset=windows-1251" /> вместо "<meta http-equiv="Content-Type" content="text/html; charset={CHARSET}" />"), не помогает. В чём может быть дело?

jeeper


0daliska

286 Errors, 35 warning(s)...

Notes and Potential Issues

The following notes and warnings highlight missing or conflicting information which caused the validator to perform some guesswork prior to validation, or other things affecting the output below. If the guess or fallback is incorrect, it could make validation results entirely incoherent. It is highly recommended to check these potential issues, and, if necessary, fix them and re-validate the document.

Character Encoding mismatch!

The character encoding specified in the HTTP header (windows-1251) is different from the value in the XML declaration (utf-8). I will use the value from the HTTP header (windows-1251).


Уехала отдыхать. Сейчас без интернета до 1 августа. Приеду - выполню все обещания
® For members of Russian community (simplemachines.ru) only

jeeper

Что же это за напасть
Не могу никак попасть.....  wallbash

Нет, ну всё равно ничего не понимаю. Откуда берется этот утф-8? В файле шаблона жестко прописана windows-1251. В настройках она же. Хэтэмээльные хедеры-футеры не при чём - что с ними, что без них ...........  wallbash