трабл с авторизацией SMF + Coppermine

Автор sstt, 13 марта 2008, 17:45:23

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

sstt

У меня такая проблема:
   Интеграция прошла в целом успешно. Но если залогиниться на форуме и потом идти по ссылке в галерею, снова требуется авторизация. Нажимаю на "вход" в галерее, перебрасывает на форум в верху страницы написано, что я пользователь такой-то и т.д. В середине форма с логином и паролем.
   Если забить логин-пароль в этой форме, ничего не произойдет, а вот если нажать на "выйти" из форума, потом снова залогиниться, но уже в поля логин-пароль вверху страницы - перебросит в галерею уже как пользователя. Затем некоторое время можно переключаться между галерей и форумом нормально. Через какоето время весь этотт процес авторизации нужно повторить.
   См. картинку ...

Avdenago

ммм.  когда включали интеграцию - какое интегрирование пользователей вы выбрали?  Там было простое и основанное на количестве сообщений?

sstt

Цитата: Avdenago от 13 марта 2008, 19:42:16
ммм.  когда включали интеграцию - какое интегрирование пользователей вы выбрали?  Там было простое и основанное на количестве сообщений?

Хм ... точно было? Вроде там такой позиции не было делал как описано тут, на форуме. У меня SMF 1.1.2, соответственно запускал интеграцию с 1.х

ksamochkin

у меня с осликом нормально, а вот в Опере не могу залогинится так же как и выше описано

OrangePLAY

SMF 1.1.4
TP 0.9.8
CPG 1.4.16
База одна.
Интеграция с простыми группами.

- при включеной интеграции зайти в галерею не получается.
Жму "Вход" - перебрасывает на форум прямо как на скрине в первом посте.
Ввод пароля ничего не даёт. - остаёшься на форуме и в гелерею всё равно не залогиниваешься.
SMF 2.0 RC 1.2

sirko

Удалось эту проблему решить? Потому что у меня точно та же самая ситуация. Причём как с простым интегрированием пользователей так и с основаным на кол-ве сообщений  :(

sirko

Пролема решилась достаточно просто. Всего навсего включил "Использовать независимые cookies для субдоменов" в настройках форума...

Asio Otus

У меня такая же проблема, только не у всех пользователей, а у некоторых. Проблема возникла после переезда на новый хостинг.  :-\

Включение независимых  cookies, не помогло. Пробовала включать интеграцию по разному (простую и  с основанную на кол-ве сообщений), также не помогло.

Плюс еще, если я пытаюсь выйти  из интегрированной галереи, то форум выдает ошибку:

Невозможно проверить месторасположение отсылаемого файла.
Пожалуйста, вернитесь назад и попробуйте снова.


Без интеграции, я нормально захожу и выхожу.   :-\

SMF -1.1.2
CGP - 1.4.8
База данных одна.
Интеграция с простыми группами.

Asio Otus

Моя проблема решилась.  :)

Убрала бридж, сменила  имя куки, поставила заново бридж. Все работает нормально.




matroskyn

а у меня вообще не хочет заходить на галлерею после авторизации.. ввожу логин и пароль, а он заходит на форум.. захожу после этого в галлерею как гость. по-другому не получается

Kinley

Всем Привет
у меня стоит SMF 1.1.8 и Coppermine Photo Gallery 1.4.16 (stable)
Интэграцию Прохожу как описано здесь
также О том как интегрировать интерфейсы систем читал здесь для меня неактуально ибо в своей верссии я таких строк как там описано ненахожу в обоих вариантах
Пытался подтянуть группы с форума способом описаным здесь неполучилось

трабла такая Захожу в галерею, требует пароль, перебрасывает в форму ввода пароля на форуме.
Ввожу пароль, попадаю на главную страницу форума.
Замкнутый круг

Что делать ?

AtonS

12 мая 2009, 00:58:14 #11 Последнее редактирование: 12 мая 2009, 02:40:37 от AtonS
Помогло! Настройки сервера -> Другие натройки -> Включить Использовать независимые cookies для субдоменов
Только теперь у меня форум НЕ запоминает пользователей! Что делать - помогите!

Lana

Всем привет! интеграция вроде заработала после включения «Использовать независимые cookies для субдоменов»

Но возникла проблема с выходом, если его делать из галереи.
Идет переброс из галереи в форум с отображением ошибки в месте формы для авторизации:
-------------
Ошибка!
Не удалось проверить сессию. Пожалуйста, выйдите из форума и зайдите снова.
-------------
При этом в  "инфомации пользователя" все еще стоит ник, т.е. выхода не произошло.

Кнопка выхода в форуме работает нормально.

Подскажите, пож, как решить проблему.

PS: cpg1.4.25+SMF 2.0 RC1-1
лучше женское имя - Елена

merkde

Цитата: Asio Otus от 23 мая 2008, 15:31:23Моя проблема решилась.  :)

Убрала бридж, сменила  имя куки, поставила заново бридж. Все работает нормально.





Спасибо, помогло при интеграции галереи 1.5.22 на форум версии 2.0.11.