Главная форума index.php отображает белый экран

Автор Cebador, 21 Октябрь 2020, 13:35:11

« назад - далее »

0 Пользователей и 1 гость просматривают эту тему.

Cebador

Доброго всем времени суток!

Суть проблемы: главная сайта равно как и http://myforum.org/index.php отображает гостям и поисковикам "чистый белый лист". Стоит запросить какую-то внутреннюю ссылку вроде: http://myforum.org/index.php?action=stat как все становится на свои места! Костыли с ModRewrite  в определенной мере решают - но это не алё, конечно  :facepalm:
Проблема возникла после апдейта с 1.1.21 на 2.0.17, сам апдейт прошёл без ошибок.
Грешил на моды, поэтому полностью зачистил их все и перезалил заново - результат тот же :-\ допускаю, что какой-то мод где-то "насвинячил" в скриптах и забыл за собой это вычистить. Долго так долбался с ошибкой при регистрации, а оказалось мод оставил лишние столбцы в базе.
"Курение" материнского форума поддержки simplemachines ничего кроме удаления модов на эту проблему не выявило.
Логи форума ничего об этом не сообщают... может кто сталкивался и знает решение, а то уже весь лоб разбил  wallbash

И ладно бы принудительная авторизация для просмотра - это даже хорошо, стимулирует юзверей региться активнее.
Но вот закрытие от индексации поисковиками - проблема посерьёзнее и как сделать форум не отображаемым гостям и при этом открытым к индексации я пока не придумал (может подскажете).

Заранее всем благодарен!

digger®

Смотреть лог ошибок php, наверняка там какая-то критическая ошибка возникает.
С 1.1 на 2.0 обновление происходит вчистую, не может там от модов ничего в скриптах остаться. Можно для чистоты эксперимента удалить все файлы кроме папки вложений и Settings.php и залить заново из дистрибутива.
Ставить надо было 2.0.15, но это уже другой вопрос.

Cebador

Цитата: digger® от 21 Октябрь 2020, 16:09:48Смотреть лог ошибок php, наверняка там какая-то критическая ошибка возникает.

/var/log/apache2/error.log - f*cking huge, могу фрагментарно или на почту выслать, но никакой крамолы кроме ругательств на неверный SSL-сертификат и не установленный Pyton (надеюсь он то SMF не нужен?:) я там абсолютно не нашёл.

/var/log/php7.3-fpm.log (именно эта версия стоит на сайте):

[21-Oct-2020 21:57:03] NOTICE: Reloading in progress ...
[21-Oct-2020 21:57:03] NOTICE: reloading: execvp("/usr/sbin/php-fpm7.3", {"/usr/sbin/php-fpm7.3", "--nodaemonize", "--fpm-config", "/etc/php/7.3/fpm/php-fpm.conf"})

[21-Oct-2020 21:57:03] NOTICE: using inherited socket fd=7, "/var/lib/php7.3-fpm/web1.sock"

[21-Oct-2020 21:57:03] NOTICE: using inherited socket fd=7, "/var/lib/php7.3-fpm/web1.sock"

[21-Oct-2020 21:57:03] NOTICE: using inherited socket fd=8, "/var/lib/php7.3-fpm/web5.sock"

[21-Oct-2020 21:57:03] NOTICE: using inherited socket fd=8, "/var/lib/php7.3-fpm/web5.sock"

[21-Oct-2020 21:57:03] NOTICE: using inherited socket fd=9, "/run/php/php7.3-fpm.sock"

[21-Oct-2020 21:57:03] NOTICE: using inherited socket fd=9, "/run/php/php7.3-fpm.sock"

[21-Oct-2020 21:57:03] NOTICE: using inherited socket fd=10, "/var/lib/php7.3-fpm/web6.sock"

[21-Oct-2020 21:57:03] NOTICE: using inherited socket fd=10, "/var/lib/php7.3-fpm/web6.sock"

[21-Oct-2020 21:57:03] NOTICE: fpm is running, pid 137

[21-Oct-2020 21:57:03] NOTICE: ready to handle connections

[21-Oct-2020 21:57:03] NOTICE: systemd monitor interval set to 10000ms

[21-Oct-2020 21:57:17] NOTICE: Reloading in progress ...

[21-Oct-2020 21:57:17] NOTICE: reloading: execvp("/usr/sbin/php-fpm7.3", {"/usr/sbin/php-fpm7.3", "--nodaemonize", "--fpm-config", "/etc/php/7.3/fpm/php-fpm.conf"})

[21-Oct-2020 21:57:17] NOTICE: using inherited socket fd=7, "/var/lib/php7.3-fpm/web1.sock"

[21-Oct-2020 21:57:17] NOTICE: using inherited socket fd=7, "/var/lib/php7.3-fpm/web1.sock"

[21-Oct-2020 21:57:17] NOTICE: using inherited socket fd=8, "/var/lib/php7.3-fpm/web5.sock"

[21-Oct-2020 21:57:17] NOTICE: using inherited socket fd=8, "/var/lib/php7.3-fpm/web5.sock"

[21-Oct-2020 21:57:17] NOTICE: using inherited socket fd=9, "/run/php/php7.3-fpm.sock"

[21-Oct-2020 21:57:17] NOTICE: using inherited socket fd=9, "/run/php/php7.3-fpm.sock"

[21-Oct-2020 21:57:17] NOTICE: using inherited socket fd=10, "/var/lib/php7.3-fpm/web6.sock"

[21-Oct-2020 21:57:17] NOTICE: using inherited socket fd=10, "/var/lib/php7.3-fpm/web6.sock"

[21-Oct-2020 21:57:17] NOTICE: fpm is running, pid 137

[21-Oct-2020 21:57:17] NOTICE: ready to handle connections

[21-Oct-2020 21:57:17] NOTICE: systemd monitor interval set to 10000ms
[21-Oct-2020 21:57:20] NOTICE: Reloading in progress ...

Cebador

Цитата: digger® от 21 Октябрь 2020, 16:09:48Можно для чистоты эксперимента удалить все файлы кроме папки вложений и Settings.php и залить заново из дистрибутива.
делал и так, только корень оставлял - там robots, htaccess с sitemap и прочие нужные вещи, index.php создавался скриптом обновления.

PS: И самое ж обидное: проблема только для гостей, у авторизированных пользователей всё работает чётко - и ни единого глюка!

S.T.A.L.K.E.R.

Форум из профиля?
Я гостем походил,точнее попытался так как везде приглашение на регистрацию
Все работает.

domofor

Цитата: Cebador от 21 Октябрь 2020, 13:35:11Суть проблемы: главная сайта ... отображает гостям и поисковикам "чистый белый лист".

Зашел на ваш форум - главная страница на сайте отображается вроде бы нормально. Или должно быть не так?

Вам недоступны вложения в этом разделе.
Сообщество владельцев форумов на любых движках https://forumovod.ru

Cebador

Цитата: S.T.A.L.K.E.R. от 22 Октябрь 2020, 05:54:13Форум из профиля?
Я гостем походил,точнее попытался так как везде приглашение на регистрацию
Все работает.
Да верно, этот форум. Это потому что я указал в админке, что гостям просмотр запрещён (а заодно и всем поисковым роботам, как я уже писал wallbash ). Стоит мне включить эту галочку - как вы увидите белый экран. 23.10.20 в 00:00  по Москве могу продемонстрировать.Вам недоступны вложения в этом разделе.

Cebador

23 Октябрь 2020, 00:51:39 #7 Последнее редактирование: 23 Октябрь 2020, 01:04:07 от Cebador
Включил опцию логгирования запросов к бд, получил несколько тысяч записей в лог такого плана:


http://***forum.org.ua/index.php?action=dlattach;topic=453.0;attach=12999;image

8: Trying to access array offset on value of type null

Файл: /var/www/clients/***/web/Sources/Load.php

Строка: 168

либо:


http://***forum.org.ua/index.php?topic=30.45

8: Trying to access array offset on value of type null

Файл: /var/www/clients/***/web/Sources/Display.php
Строка: 713 или 715



ссылки в первой строке постоянно меняются, но строки и файлы скриптов одни и те же,
не уверен что это связано с моей проблемой, но может знающие подскажут куда копать  ::) :coolsmiley:

S.T.A.L.K.E.R.

Сделайте так чтобы была ошибка 500 сейчас
И потом посмотрите в лог ошибок.

Cebador

23 Октябрь 2020, 17:17:35 #9 Последнее редактирование: 23 Октябрь 2020, 17:45:37 от Cebador
Цитата: S.T.A.L.K.E.R. от 23 Октябрь 2020, 17:11:56Сделайте так чтобы была ошибка 500 сейчас
И потом посмотрите в лог ошибок.
Так у меня её и не было! :o

Она может возникнуть только если переключиться на старую версию PHP 5.6 например. :coolsmiley:

PS: Кстати лог форума продолжает забиваться вышеописанными ошибками, несмотря на то, что я запретил гостевой просмотр и отключил регистрацию ошибок базы данных. Как-то всё это странно...может я нахоботил с правами доступа? Сейчас на всё стоит 775, на attachments и cache 777. Через админку форума вообще не могу ничего делать с правами доступа к папкам, только через консоль. По той же причине не могу нормально скачивать и устанавливать моды с репозиториев, только вручную залитые в /Packages устанавливаются. Буду благодарен за ссылку на точную настройку прав доступа в каталоге форума версии 2.0.

S.T.A.L.K.E.R.

Цитата: Cebador от 23 Октябрь 2020, 17:17:35Так у меня её и не было! :o
Ну так и не была,и хер с ней.В чем тогда проблема?

Cebador

в этом:
Вам недоступны вложения в этом разделе.

и в этом:
Вам недоступны вложения в этом разделе.

S.T.A.L.K.E.R.

Вам нужно внимательно посмотреть в логе ошибок,там должна быть критическая ошибка.
Если ошибки там нет то значит нужно настроить вывод критических ошибок или на экран или в лог.
Пока Вы это не сделаете понять что там за ошибка невозможно.

Cebador

Цитата: S.T.A.L.K.E.R. от 24 Октябрь 2020, 13:13:49Вам нужно внимательно посмотреть в логе ошибок,там должна быть критическая ошибка.
Если ошибки там нет то значит нужно настроить вывод критических ошибок или на экран или в лог.
Пока Вы это не сделаете понять что там за ошибка невозможно.
Критические только связаны с попыткой мною же прикрепить слишком большое вложение. Вот всё что там накопилось за неделю: Вам недоступны вложения в этом разделе.

Если я что-то не включил вроде детализации логов - подскажите где, я включу!

S.T.A.L.K.E.R.

Цитата: Cebador от 26 Октябрь 2020, 02:09:24Критические только связаны с попыткой мною же прикрепить слишком большое вложение.
Это надо смотреть лог ошибок на хостинге,а не в админке.

Cebador

Цитата: S.T.A.L.K.E.R. от 27 Октябрь 2020, 18:56:46Это надо смотреть лог ошибок на хостинге,а не в админке.
Я уже показывал логи, какие ещё нужны я не знаю - скажите какие - вышлю!

у меня есть идея попробовать установить сертификат и включить глобальный режим HTTPS с авторедиректом http в https. Отпишусь решит ли это проблему.

Вернёмся ко второму вопросу в шапке (для знающих) есть ли способ сделать форум закрытым для гостевого просмотра и при этом полностью открытым поисковым системам? (sitemap установил, но само по себе это проблему не решает, т.к. в выдаче все заголовки упираются в сообщение "войдите или зарегистрируйтесь").

S.T.A.L.K.E.R.

Цитата: Cebador от 29 Октябрь 2020, 01:45:39Вернёмся ко второму вопросу в шапке (для знающих) есть ли способ сделать форум закрытым для гостевого просмотра и при этом полностью открытым поисковым системам? (sitemap установил, но само по себе это проблему не решает, т.к. в выдаче все заголовки упираются в сообщение "войдите или зарегистрируйтесь").
Есть.Создать отдельную группу для поисковых ботов.

Cebador

Цитата: S.T.A.L.K.E.R. от 29 Октябрь 2020, 05:58:06Есть.Создать отдельную группу для поисковых ботов.
Сделал "Spiders", наследовал права от "Обычные пользователи", добавил всех туда через настройки Поисковых систем, но как-то всё-равно они sitemap не индексируют, точнее индексируют без авторизации только заголовки, а так чтоб с темами может через служебную учётку пользователя реально или это фантастика?

Cebador

Докладываю: прикрутил SSL, ничего не изменилось - всё так же не отображается главная в гостевом доступе. Осталось последнее - ещё раз перезалить начисто базу и распаковать smf_2-0-17_upgrade.tar.gz в чистый каталог с attachments и Settings.php, если история продолжится - значит проблема 99% где-то внутри базы. И тогда уже скорее всего попрошу помощи местных спецов за $.

PS: С поисковыми ботами вроде разобрался - пошла понемногу индексация набирать обороты  O0


Cebador

Цитата: digger® от 06 Ноябрь 2020, 20:23:20Проверьте что установлен php7.3-mbstring
Есть. Во-всяком случае инсталлятор сообщает что есть:


Код
root@ad**b-de:~# php -v
Код
PHP 7.3.24-3+0~20201103.72+debian10~1.gbp945915 (cli) (built: Nov  3 2020 14:31:51) ( NTS )

Код
root@ad**b-de:~# apt install php7.3-mbstring                    
Reading package lists... Done
Building dependency tree   
Reading state information... Done
php7.3-mbstring is already the newest version (7.3.24-3+0~20201103.72+debian10~1.gbp945915).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.