Выпущен SMF 2.1 RC1

Автор digger®, 05 Февраль 2019, 22:19:50

« назад - далее »

0 Пользователей и 1 гость просматривают эту тему.

digger®

Команда Simple Machines рада объявить о выпуске SMF 2.1 RC1. Этот первый релиз-кандидат для SMF 2.1, который завершает фазу бета-разработки и является одним из последних шагов на пути к официальному выпуску SMF 2.1. Многочисленные ошибки, о которых сообщалось после выпуска Beta 3, были исправлены, и были улучшены безопасность, стабильность и производительность.

Основные улучшения:
  • Много улучшений и оптимизаций работы с БД.
  • Улучшения SCEditor, jQuery и некоторых других плагинов и библиотек.
  • Улучшения проксирования изображений и поддержка внешних прокси.
  • Улучшенный парсер BBCode.
  • Полная поддержка IRIs (интернациональные URL).
  • Локализация reCaptcha.
  • Возможность локализации описаний часовых поясов.
  • Переписаны некоторые языковые строки, чтобы сделать их более понятными.
  • Полная переделка встроенного языкового редактора.
  • Больше возможностей для пользовательских полей профиля.
  • Улучшения двухфакторной авторизации.
  • Расширенный журнал ошибок, включбщий информацию о трассировке ошибок.
  • Исправления ошибок для уведомлений и оповещений.
  • Поддержка дробных значений в платных подписках.
  • Наборы смайлов теперь могут использовать много разных форматов изображений.
  • Множество улучшений и исправлений шаблонов и CSS.
  • Более интеллектуальная минимизация CSS и JavaScript.
  • Еще больше новых хуков интеграции.

Вы можете прочитать об этих и других улучшениях в чейнджлоге на GitHub.

Термин "Release Candidate" означает, что разработчики полагают, что эта версия программного обеспечения достаточно надежна для установки и использования на действующих веб-сайтах. Тем не менее, возможно появление незначительных ошибок в работе SMF 2.1 RC1. Мы рекомендуем вам сообщать о любых найденных ошибках.

Вы можете установить SMF 2.1 RC1 как новый форум или обновится на него с SMF 2.0.15 или любой другой предыдущей версии. Вы можете загрузить пакет установки или обновления со страницы загрузки. Вы можете посмотреть раздел Установка и обновление SMF в онлайн-руководстве, чтобы узнать больше. Обратите внимание, что обновление с любой бета-версии до RC1 не поддерживается.

Авторам модификаций и тем оформления рекомендуется проверять план предстоящих этапов разработки при принятии решения об обновлении их модификаций и тем для SMF 2.1. В целом, большинство авторов модов имеют возможность начать свою работу уже сейчас, в то время как авторы тем могут подождать RC2.

Команда Simple Machines

Оригинал: https://www.simplemachines.org/community/index.php?topic=564881.0

GeorG

[attach name=.jpg type=image/jpeg]15892[/attach]

Думал не доживу до этого момента :D
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

S.T.A.L.K.E.R.

Цитата: digger® от 05 Февраль 2019, 22:19:50Обратите внимание, что обновление с любой бета-версии до RC1 не поддерживается.
То есть вот этим людям которые есть тут на форуме и которые пообновляли свои форумы до различного состояния бет теперь можно свои форумы выкинуть в топку из за невозможности обновиться до RC?
Просто охренительная новость для них,и для этого форума в том числе.

Snow_Irbis

Замечательная новость :) Правильно ли я понял что если у меня версия 2.0.13 то можно сразу апгрейдится на SMF 2.1 RC1 без установки апдейтов 2.0.14+2.0.15? И есть ли смысл апдейтится сразу, или лучше подождать выхода версии без RC, которая как мне кажется уже не за горами?

GeorG

Цитата: Snow_Irbis от 06 Февраль 2019, 10:37:14можно сразу апгрейдится на SMF 2.1 RC1
Можно.

Цитата: Snow_Irbis от 06 Февраль 2019, 10:37:14или лучше подождать выхода версии без RC
100% лучше подождать релиза.

Цитата: Snow_Irbis от 06 Февраль 2019, 10:37:14которая как мне кажется уже не за горами?
Я бы так не предполагал.

Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

S.T.A.L.K.E.R.

Я в 2016 на бете2 думал что RC не за горами. Прошло всего три года

Snow_Irbis

Цитата: GeorG от 06 Февраль 2019, 10:43:45100% лучше подождать релиза.

Понял, значит буду ждать релиза и пробовать на локалке SMF 2.1 RC1

Цитата: S.T.A.L.K.E.R. от 06 Февраль 2019, 10:51:00Я в 2016 на бете2 думал что RC не за горами. Прошло всего три года

По меркам Вселенной это всего ничего ;)
 

digger®

Цитата: S.T.A.L.K.E.R. от 06 Февраль 2019, 08:03:45То есть вот этим людям которые есть тут на форуме и которые пообновляли свои форумы до различного состояния бет теперь можно свои форумы выкинуть в топку из за невозможности обновиться до RC?
Просто охренительная новость для них,и для этого форума в том числе.
Думаю, что имелось в виду отсутствие пакетных обновлений. Наверняка, large upgrade обновит и с беты.

S.T.A.L.K.E.R.

Гм,я уже и оригинал сходил почитать,пока не ясно. Нужно подождать пока прояснится

donfisher

Посмотрел, поклацал. Разницу между Beta 4 не увидел.

GeorG

Вроде редактор изменился.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

donfisher

Цитата: GeorG от 06 Февраль 2019, 21:28:57Вроде редактор изменился.

Редактор чего?


donfisher

После обновления пользователей выбрасывает? Заново надо авторизовываться?

Mavn

Цитата: donfisher от 06 Февраль 2019, 21:25:28Посмотрел, поклацал. Разницу между Beta 4 не увидел.
визуально различий можно и не увидеть, я думаю там вопрос в фиксе кучи ошибок...
SimpleMachines Russian Community Team
п.1 Пройду курсы гадалок для определения исходного кода по скриншоту.

п.2 У вас нет желания читать правила раздела, у меня нет желания одобрять темы, которые не соответствуют этим правилам.

GeorG

Цитата: donfisher от 06 Февраль 2019, 21:36:23Редактор чего?
Редактор ответа.
Я может подзабыл немного (т.к. не заходил на форум), но вроде не было по умолчанию тег обтекания и ютуба.

Кнопка "Предварительный просмотр" стоит перед "Отправить", и я по привычки жму на первую, тем самым попадаю на страницу полного ответа, вместо того чтобы сразу отправить, с "быстрого".

UPD:
Видимо что-то изменилось в якоре прикрепления вложений, т.к, моё изображение не прикреплено в сообщении (виден только тег), а отображается под сообщением, как обычное вложение.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

S.T.A.L.K.E.R.

 @GeorG редактор изменился,ютуба и сворачивания не было. Поле для ввода текста у меня на мобильном свернуло в узкую полосу на две строчки текста. И да,вложения все так поломало :facepalm:

donfisher

Цитата: GeorG от 07 Февраль 2019, 08:27:44Редактор ответа.
Я может подзабыл немного (т.к. не заходил на форум), но вроде не было по умолчанию тег обтекания и ютуба.

Кнопка "Предварительный просмотр" стоит перед "Отправить", и я по привычки жму на первую, тем самым попадаю на страницу полного ответа, вместо того чтобы сразу отправить, с "быстрого".

UPD:
Видимо что-то изменилось в якоре прикрепления вложений, т.к, моё изображение не прикреплено в сообщении (виден только тег), а отображается под сообщением, как обычное вложение.

Все это есть в beta 4.

S.T.A.L.K.E.R.

Цитата: GeorG от 07 Февраль 2019, 08:27:44Видимо что-то изменилось в якоре прикрепления вложений
Изменилось и кардинально
Код: (старое)
[attach name=.jpg type=image/jpeg]15892[/attach]
Код: (новое)
[attach id=15895]2019-02-07 09_43_04-Greenshot.jpg[/attach]
Я так понимаю теперь старым вставкам борода?

digger®

Цитата: S.T.A.L.K.E.R. от 07 Февраль 2019, 21:04:25Изменилось и кардинально
Я так понимаю теперь старым вставкам борода?
В этом то и весь драйв использования беток - в следующей версии что-нибудь может кардинально поменяться.

donfisher

Цитата: S.T.A.L.K.E.R. от 07 Февраль 2019, 21:04:25Изменилось и кардинально
Код: (старое)
[attach name=.jpg type=image/jpeg]15892[/attach]
Код: (новое)
[attach id=15895]2019-02-07 09_43_04-Greenshot.jpg[/attach]
Я так понимаю теперь старым вставкам борода?

То есть старые картинки не будут показываться в новой версии?
Примеры на этом форуме можно посмотреть?

digger®

Цитата: donfisher от 08 Февраль 2019, 00:38:35То есть старые картинки не будут показываться в новой версии?
Примеры на этом форуме можно посмотреть?
Картинки показываться будут, просто они станут обычными вложениями, а не изображениями в тексте сообщения.
На Beta3 все равно эта вставка толком не работала, так что вряд ли много таких вложений.

GeorG

Теперь только скрипт писать, по поиску и замены в БД.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

S.T.A.L.K.E.R.

Цитата: GeorG от 08 Февраль 2019, 10:29:46Теперь только скрипт писать, по поиску и замены в БД.
Скоро начнутся тут расспросы.

Serifa

Цитата: S.T.A.L.K.E.R. от 06 Февраль 2019, 08:03:45Просто охренительная новость для них,и для этого форума в том числе.
Так, а у меня как раз база форума была апгрейднута под бету вторую даже(
Цитата: digger® от 06 Февраль 2019, 21:45:26Обновилось с Beta3 как по маслу.
Или есть шанс?

Все равно фору буду ставить с нуля, главное-то - базу воткнуть прежнюю.

Ну и да, картинки... Впрочем, их проще просто все выкинуть. Поиском по базе?))
версия форума 2.1
«- Помощник капитана Бакстер, - заявил Лумис, - безбожно врет. Все отнюдь не под контролем, вернее, не под его контролем. Корабль захвачен представителями небелковой формы разумной жизни, которые маскируются под обслуживающих роботов, а некоторые даже не делают и этого...»
«То, что у тебя есть, лечится антибиотиками» (nowhere man, 1995)
В телеге

S.T.A.L.K.E.R.

Ставишь бету2 апгрейд до RC1
Картинки если где вставлены в сообщения с ними думать надо. Надо смотреть будет

plintus

А у меня вложения робят. Обновлялся с 2.0.15 до 2.1 beta 3. Щас накатил чистую и залил туда базу.
Надёжный хостинг - быстрее быстрого на SSD-дисках от 120 руб/мес  с доменом в подарок Промо-код на скидку в 10%: Skid10

S.T.A.L.K.E.R.

Цитата: plintus от 08 Февраль 2019, 19:17:00А у меня вложения робят. Обновлялся с 2.0.15 до 2.1 beta 3. Щас накатил чистую и залил туда базу.
Вставленные в сообщения картинки,а не вложения.Вложения работают и так.

donfisher

После обновления пользователей выбрасывает? Пользователю заново надо авторизовываться?

S.T.A.L.K.E.R.

Цитата: donfisher от 08 Февраль 2019, 20:09:37После обновления пользователей выбрасывает? Пользователю заново надо авторизовываться?
Да.

nefact

Спасибо, замечательная новость! А я только закончил все модификации и собирался ставить форум, будем делать уже на новой версии.

plintus

Цитата: S.T.A.L.K.E.R. от 08 Февраль 2019, 19:35:39Вставленные в сообщения картинки,а не вложения.Вложения работают и так.
Поменяйте версию PHP на 5.4 Всё заработало!
Надёжный хостинг - быстрее быстрого на SSD-дисках от 120 руб/мес  с доменом в подарок Промо-код на скидку в 10%: Skid10

donfisher

Кстати в одном из дивов Beta 4 при добавлении поста с со ссылкой на ролик в ютуб, в опубликованном посте появлялся плеер с этим роликом. То есть без нажатия кнопки ютуб, ссылка автоматом трансформировалась в плеер с роликом.
Жаль, что в RC1 этого не реализовали.

wbmpm

бредовый релиз (( даже админа не хочет авторизовать и это при чистой установке.. ой как не завидую тем, кто обновлялся с предыдущих

Snow_Irbis

Цитата: plintus от 09 Февраль 2019, 12:37:22Поменяйте версию PHP на 5.4 Всё заработало!
Так вроде начиная с 2.0.14 нужна версия PHP не ниже 5.6

Hatshepsut

Цитата: Snow_Irbis от 28 Февраль 2019, 20:23:04Так вроде начиная с 2.0.14 нужна версия PHP не ниже 5.6

Нет, минималная версия PHP 5.4  :)

Mavn

Цитата: Hatshepsut от 01 Март 2019, 07:59:33Нет, минималная версия PHP 5.4  :)
там если внимательно прочитать
ЦитироватьPHP 5.4.0 or higher
... PHP 5.5 it is required to use SMF 2.0.7 or greater.
смысл следующий 5.4 действительно минимальная версия, но для первых версий 2.0 начиная с 2.0.7 мин версия 5.5 для последней версии уточняющей информации от разработчиков не нашел, но что то подсказывает что php 5.5 мин версия
SimpleMachines Russian Community Team
п.1 Пройду курсы гадалок для определения исходного кода по скриншоту.

п.2 У вас нет желания читать правила раздела, у меня нет желания одобрять темы, которые не соответствуют этим правилам.

Snow_Irbis

Цитата: Mavn от 01 Март 2019, 13:57:46там если внимательно прочитать смысл следующий 5.4 действительно минимальная версия, но для первых версий 2.0 начиная с 2.0.7 мин версия 5.5 для последней версии уточняющей информации от разработчиков не нашел, но что то подсказывает что php 5.5 мин версия
Странно странно, у меня до недавнего времени два форума использовали PHP версии 5.3.10 (версия форумов 2.0.13), а вот обновление до 2.0.14 и 2.0.15 нормально прошло только после смены версии PHP минимум до 5.6.39 (если ниже, то при открытии форума белая страница с ошибкой, при этом смена версии PHP минимум до 5.6.39 устраняла ошибку без дополнительных модификаций файлов и БД), поэтому я думал что минимальная версия PHP для версий форумов начиная с 2.0.14 это 5.6  :)