Проблема с https помогите?

Автор worki87, 08 июня 2018, 15:36:36

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

worki87

repair_settings.php Здесь я все поменял на https.
В настройках/плюшки и сессии включил шифровать куки.
В итоге сайт доступен как по https так и по http.
Как это исправить, я новечек в SMF!

S.T.A.L.K.E.R.

В .htaccess прописать редирект с http на https

worki87

Цитата: S.T.A.L.K.E.R. от 08 июня 2018, 16:02:51В .htaccess прописать редирект с http на https


Ну это я сделал, вроде врубилось но пишет что соединение на защищено, в чем может быть проблема? Может надо файл ключа положить в папку с форумом?

S.T.A.L.K.E.R.

Цитата: worki87 от 08 июня 2018, 16:24:56Ну это я сделал, вроде врубилось но пишет что соединение на защищено, в чем может быть проблема? Может надо файл ключа положить в папку с форумом?
Ссылку дайте на форум,скорее всего где-то смешанное содержимое может подгружаться.В консоли разработчика нужно смотреть.

GeorG

В админке в настройках сервера, надо включить опцию проксирование изображений.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

worki87

Цитата: S.T.A.L.K.E.R. от 08 июня 2018, 17:37:30Ссылку дайте на форум,скорее всего где-то смешанное содержимое может подгружаться.В консоли разработчика нужно смотреть.

Тут я разобрался, сертификат не сразу начал работать от хостера.
Сделал я редирект вот по такой схеме.

Предварительно в админке / конфигурации сервера / плюшки и сессии  - поставил галочку шифровать cookies

1) скачал файл repair_settings.php загрузил в папку с форумом в корень, перешел по ссылки

2) http://ссылкавашегосайта.ру/repair_settings.php


3) открылся файл с настройками, там везде в ссылках где были http:// я изменил их на https:// и сохранил.

4) удалил с корня файл repair_settings.php
 

5) создал файл .htaccess.txt и положить в корень папки с форумом, прописать в нем следующие!

RewriteCond %{HTTPS} !=on
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]


Сейчас форум переадресовывается только на https://

 

Antonii

Цитата: worki87 от 09 июня 2018, 10:35:33Тут я разобрался, сертификат не сразу начал работать от хостера.
Сделал я редирект вот по такой схеме.

Предварительно в админке / конфигурации сервера / плюшки и сессии  - поставил галочку шифровать cookies

1) скачал файл repair_settings.php загрузил в папку с форумом в корень, перешел по ссылки

2) http://ссылкавашегосайта.ру/repair_settings.php


3) открылся файл с настройками, там везде в ссылках где были http:// я изменил их на https:// и сохранил.

4) удалил с корня файл repair_settings.php
 

5) создал файл .htaccess.txt и положить в корень папки с форумом, прописать в нем следующие!

RewriteCond %{HTTPS} !=on
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]


Сейчас форум переадресовывается только на https://

 
Я так понимаю это мануальчик по переходу на https, а то я не могу сконфигурировать сайт для https, нужен мануал. Когда оставляю всё как есть/ Я просто когда тупо перехожу на https у хоста. То у меня тема пропадает, только текст и незпщпщённое подключение

S.T.A.L.K.E.R.

Цитата: Antonii от 11 июня 2019, 17:29:09Я так понимаю это мануальчик по переходу на https, а то я не могу сконфигурировать сайт для https, нужен мануал. Когда оставляю всё как есть/ Я просто когда тупо перехожу на https у хоста. То у меня тема пропадает, только текст и незпщпщённое подключение
В помощь - https://www.simplemachines.ru/index.php?msg=112080
Измените пути на https