Перенос форума из SMF 2.0 в SMF 2.0

Автор Участник форума, 03 декабря 2017, 21:30:05

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

Участник форума

Здравствуйте, скажите, пожалуйста, может ли такое сделать не веб-программист и человек, который постоянно не занимается SMF, а является просто пользователем SMF.

Я хочу установить SMF 2.0.15 с нуля.
Сейчас у меня есть форум на версии 2.0.13.

Как мне перенести имеющиеся данные из версии 2.0.13 на версию 2.0.15?

Просто у меня уже второй раз не получается обновить. Мне кажется, что это как-то связано с русским языком.
Я хочу перейти на английский язык, чтобы новые версии форума работали.

kak2z

может))
попробуйте сделать бекап форума, на всякий случай..
а потом просто взять полный пакет 2.0.15 и перезалить в директорию с форумом, только оставив при этом файл settings.php
Если нужно что то исправить, обновить, переставить, настроить, сделать форум заново - пишите в ЛС)

GeorG

Цитата: Участник форума от 03 декабря 2017, 21:30:05Мне кажется, что это как-то связано с русским языком.
Видимо кодировка на форуме win1251, потому и проблемы.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

Участник форума

Сразу не ответил, т.к. думал, что у меня есть уведомления, а их не оказалось.

kak2z, попробую ваш способ.
GeorG, использовал этот способ, от Макара. У меня: var smf_charset = "UTF-8";

Участник форума

kak2z, я сделал по аналогии с вашей рекомендацией, но вместо полной установки, использовал Large Upgrade.
На первый взгляд проблем нет.
Это получается, что проблема не в обновлении, а в установщике обновления?

GeorG

Цитата: Участник форума от 11 декабря 2017, 19:33:33GeorG, использовал этот способ, от Макара.
Это форум, а сама БД?

Large Upgrade снесла вам все моды если такие были, вот и всё. Если правильно делать, то нужно просто патч ставить.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

Участник форума

GeorG, а где можно посмотреть кодировку базы данных?
К чему вы это написали, я не понял: Large Upgrade снесла вам все моды если такие были, вот и всё. Если правильно делать, то нужно просто патч ставить.

Цитата:
Если правильно делать

Вообще, есть же официальный файл для обновления. Куда ещё правильнее?

Участник форума

Посмотрел кодировку на хостинге, в phpMyAdmin в "Сопоставление кодировки соединения"  указано "utf-8_general_ci".

GeorG

Цитата: Участник форума от 11 декабря 2017, 22:28:12К чему вы это написали, я не понял
Поясню, - у вас же была версия 2.0.13, а пакет Large Upgrade применяют например, чтобы обновится с первой ветки форума (1.1.х), вам бы хватило установить патч(и) с этой страницы - https://custom.simplemachines.org/upgrades/
И такое обновление, не снесло бы все уже установленные моды и не пришлось бы все по новой настраивать.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

Участник форума

GeorG, спасибо попробую так сделать в следующий раз (при следующем обновлении).

Участник форума

GeorG, но есть нестыковка. Вот что написано на офиц. сайте про Large Upgrade:
Large upgrade
Upgrading from an earlier branch (SMF 2.0.14 or below)? No problem, this is what you need. This archive will upgrade/reset your forum to a clean install of the latest version and will remove all modifications.

Обращаю внимание на эту фразу:
Upgrading from an earlier branch (SMF 2.0.14 or below)?

Здесь упоминается SMF 2.0.14, а не SMF 1. Зачем на офиц. сайте советуют это, а не патч?

GeorG

Ключевое выделил жирным:
Цитата: Участник форума от 12 декабря 2017, 15:28:31Upgrading from an earlier branch (SMF 2.0.14 or below)

Т.е, при обновлении, вы бы обновили то что есть, без потерь, при апгрейде вы снесли все и получили обновленную версию движка. Всё это я писал уже выше.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru