SMF + MODx + SSI = знаки вопросов вместо русских букв

Автор AXX, 31 октября 2017, 22:18:06

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

AXX

Не уверен что точно идентифицировал проблему.
Есть сайт на MODx UTF8, есть форум SMF 2.0.14 Win1251.
Есть вывод последних тем форума на сайт через SSI где вместо русских символов с некоторого времени стали вопросы выводится, причем если запустить forum/ssi_examples.php выводится все корректно, в связи с чем подозрение что это из-за связки проблемы. С другой стороны есть SET NAMES UTF8 который по идее эту проблему должен решить.
В чем может быть проблема?

ЗЫ: переводить базу форума в UTF8 не вариант, форум древний, куча доработок, я не уверен что все корректно станет, хотелось бы если есть решение более простое, то воспользоваться им.

AXX

вопрос снят. я был прав в одном - не уверен что верно идентифицировал проблему. проблема была во мне и устаревшем обращении в базе. после обновления mysql все сломалось(

kak2z

попробуйте конвертировать все таки.. сделайте тестовую базу и конвертируйте.. я не думаю что могут какие то экстраординарные проблемы возникнуть изза смены кодировки.. по  крайней мере не встречал..

Если нужно что то исправить, обновить, переставить, настроить, сделать форум заново - пишите в ЛС)

AXX

да нет особо времени на эксперименты. работает - я не трогаю :)
если бы не нашел решение вчерашней проблеме может и конвертировал бы, а так - подожду до следующей проблемы

GeorG

Цитата: AXX от 31 октября 2017, 22:18:06через SSI где вместо русских символов с некоторого времени стали вопросы выводится
Видимо проблема обнаружилась как только обновились до версии 2.0.14, а она не может нормально работать с win1251.
Если так, то поможет откат на версию 2.0.13, или меняйте кодировку на utf8 (ибо дальше, будет только больше проблем).
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

AXX

а почему не может? вполне работает.
проблема обнаружилась когда заглянул в на главную, где выводился блок последних новостей с форума. видимо, те, кто форум читает сразу на него и заходили, а остальным было в лом писать, потому что они на форум не ходят.

valdnieks

Цитата: GeorG от 02 ноября 2017, 16:43:18Видимо проблема обнаружилась как только обновились до версии 2.0.14, а она не может нормально работать с win1251.

Странно. Может другая причина. У меня отлично работает. Кстати @GeorG, Вы знаете, что у меня атомная бомба.
Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

GeorG

Цитата: AXX от 02 ноября 2017, 17:33:16а почему не может? вполне работает.
Ну мочь то оно может, но вот с различными ненормальностями.
Форум с патчем 2.0.14 требует версию php 5.4 и выше, а там уже в свою очередь другие требования к системе в целом (где кодировка win1251 оказывается не рекомендуемой, и в большинстве своём, не рабочей), это уже обсуждалось на форуме.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

AXX

Цитата: GeorG от 02 ноября 2017, 21:24:37Ну мочь то оно может, но вот с различными ненормальностями.
Форум с патчем 2.0.14 требует версию php 5.4 и выше, а там уже в свою очередь другие требования к системе в целом (где кодировка win1251 оказывается не рекомендуемой, и в большинстве своём, не рабочей), это уже обсуждалось на форуме.

все верно, пхп 5.4.45, обновил еще раньше, чтобы не было грустно и в результате - все нормально работает

GeorG

Цитата: AXX от 31 октября 2017, 22:18:06через SSI где вместо русских символов с некоторого времени стали вопросы выводится
!=
Цитата: AXX от 02 ноября 2017, 21:45:08в результате - все нормально работает

Сами себе противоречите, собственно дело ваше, вы просили указать на причину, я вам показал :)
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

AXX

я недостаточно подробно описал хронологию событий потому что неверно сначала идентифицировал проблему. вот как все было
1. Условно в начале этого года я добавил к форуму на SMF сайт с несколькими статичными страницами на MODx и на главную вывел блок последних новостей через SSI. Уже тогда были проблема с вопросительными знаками и я ее решил через mysql_query (SET NAMES UTF8) - нашел где-то в инете, это сработало и я оставил эту тему.
2. где-то летом, когда было свободное время я решил обновить php, потому что некоторым другим сайтам на этом хостинге уже была нужна новая версия и как показывает текущее обновление и SMF был на подходе. После обновления форум работал корректно, а блок последних новостей я не проверял, хотя уже в тот момент проблема была - потому что новая версия php не поддерживала обращение mysql_query и соответственно эта строка кода не обрабатывалась. Но сам форум вполне нормально работал.
3. В наши дни я обновился на 2.0.14 и проблем тоже не заметил.
4. Позже, я обнаружил вопросительные знаки, но в связи с тем что давно не мониторил работу данного модуля не стал делать выводы о причинах неполадок, формально, последние работы на сайте были именно по обновлению форума.
5. После того как была обнаружена причина, я исправил неработающий запрос и все снова заработало.
Если бы не модуль вывода последних тем через SSI проблем бы не было вообще - сам форум как работал, так и работает с кодировкой win1251.

GeorG

 :facepalm:

У вас не с форумом проблемы, а в той системе где это всё крутится беда, проблему я вам сказал, это то что у вас кодировка в win1251 при версии php 5.4, перейдите на версию php 5.3, то всё опять будет работать нормально, но сам форум тогда не сможет работать с патчем 2.0.14 (тогда и его откатить придётся). Честное слово, я не знаю как вам ещё объяснять эти очевидные вещи (а просто уже "слагаемые" проблемы перестраиваю в своих предложениях, итог от этого не меняется - меняйте кодировку).

Вы просили найти проблему, я её нашёл, если вы не согласны с ней, то можете ничего не менять, и оставаться со своими проблемами ;)
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

AXX

честно говоря я тоже не знаю как еще написать - сейчас проблем нет, даже если вы считаете что они есть :)
работает smf 2.0.14 (win 1251) на php 5.4 + MODx (utf8) без проблем.

проблема была и я описал как ее решил ничего не откатывая, там поправить одну строчку надо было.

S.T.A.L.K.E.R.

 @AXX сейчас проблем нет,но с win 1251 у Вас всё ещё впереди.Прийдется отказываться от обновлений в будущем.Как php так и SMF.

AXX

это было очевидно и 10 лет назад, однако прошло 10 лет - проблем пока нет. будут - обновлюсь.
Цитата: AXX от 01 ноября 2017, 18:26:10работает - я не трогаю
:)

AXX

и еще вопрос по поводу возможного перехода на utf8 - находил инструкцию от Mavn и что-то второй раз не могу найти  wallbash  никто не знает в какой теме она может быть?