Ошибка при установки с 2.0.13 на 2.0.14

Автор misterX, 12 сентября 2017, 11:48:43

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

misterX

12 сентября 2017, 11:48:43 Последнее редактирование: 12 сентября 2017, 12:03:24 от misterX
Ошибка при установки с 2.0.13 на 2.0.14.  Сервер на CentOS-6-amd64.
Пишет: "Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later. "
Что это может значить и как это исправить?

GeorG

Цитата: misterX от 12 сентября 2017, 11:48:43Ошибка при установки с 2.0.13 на 2.0.14.
Какой ещё установке? о_О!
Там же обновление надо делать - ставить фикс.

А так пишет ошибку, что не может подключится к БД, значит данные неверные, но вам всё равно только патч надо ставить, а не обновляться, что вы наверное пытаетесь сделать.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

misterX

Цитата: GeorG от 12 сентября 2017, 13:25:25Какой ещё установке? о_О!
Там же обновление надо делать - ставить фикс.

А так пишет ошибку, что не может подключится к БД, значит данные неверные, но вам всё равно только патч надо ставить, а не обновляться, что вы наверное пытаетесь сделать.

когда заходишь менеджер пакетов пишет:
 "A few security vulnerabilities and bugs in SMF 2.0.13 have been fixed. You can install this patch (click here to install) to fix your forum and update it to 2.0.14.

If you have any problems applying it, you can use the version posted on the downloads page - although, any modifications you have installed will need to be uninstalled. Please post on the forum if you need more help."
Так вот я нажимаю "click here to install" и обновляю или устанавливаю (незнаю как это лучше назвать) как мод.

GeorG

Ну может случайный баг какой на сервере был с подключением, вы несколько раз пробовали и всегда одно и тоже?
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

misterX

Цитата: GeorG от 12 сентября 2017, 19:49:13Ну может случайный баг какой на сервере был с подключением, вы несколько раз пробовали и всегда одно и тоже?
несколько раз пробывал в разные дни и даже разные месяцы и всегда одно и тоже, при чем с 2.0.12 на 2.0.13 обновлялось без проблем

GeorG

Это происходит при установки модов, или только при установке патча?
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

misterX


misterX

что нет даже никаких предположений?


misterX

Цитата: digger® от 16 сентября 2017, 21:45:55Какая версия php, поддержка mysqli включена?
где это можно посмотреть?)

misterX

Цитата: digger® от 16 сентября 2017, 21:45:55Какая версия php, поддержка mysqli включена?
Версия MySQL: 5.1.73
PHP: 5.3.3

misterX

Цитата: S.T.A.L.K.E.R. от 16 сентября 2017, 22:45:10Нигде.Ответ выше переадресуйте хостеру.Это к нему 100%
Нет - если дадите полномочия могу я пообщаться.
а в "Поддержка и благодарности"  в админке разве не они написаны?
Версия MySQL: 5.1.73
PHP: 5.3.3


PS
Как то можно повысить PHP до версии 5.4?)

misterX

Цитата: S.T.A.L.K.E.R. от 16 сентября 2017, 23:04:02Там создатели SMF.
Косяк - не зависимо от платформы хостер.
Вам хоть что-то мод секьрити говорит?
ничего не говорит.
лучше вы скажите что нужно делать)


misterX

Цитата: digger® от 16 сентября 2017, 23:25:44Для SMF 2.0.14 нужна минимальная версия php 5.4
а как можно повысить до версии 5,4?

GeorG

Цитата: misterX от 16 сентября 2017, 23:36:03а как можно повысить до версии 5,4?
У хостера спросите, бывает что прямо через панель управления хостингом переключается.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

misterX

Хостер ответил:
"К сожалению, на при использовании других версий PHP сайт не работает. Уточните, пожалуйста, модули PHP, которые нужны для его работы."

Какие модули PHP нужны?

GeorG

Вам уже написали, нужна версия php 5.4 и выше, а не просто модуль, если у вас сайт не работает с такой версией php, то обновляете и сайт тоже, или не обновляете форум, оставайтесь на 2.0.13, тут другого выхода нет. :)
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

misterX

Цитата: GeorG от 19 сентября 2017, 14:01:07Вам уже написали, нужна версия php 5.4 и выше, а не просто модуль, если у вас сайт не работает с такой версией php, то обновляете и сайт тоже, или не обновляете форум, оставайтесь на 2.0.13, тут другого выхода нет. :)
у меня нет сайта, только форум, мне нужно обновить форум до 2,0,14 и он тогда перестанет работать и будет писать "Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later." и в это время просить хостера чтобы он обновил до php 5.4, и тогда якобы всё должно заработать, правильно я понимаю?)

GeorG

Цитата: misterX от 19 сентября 2017, 13:49:32К сожалению, на при использовании других версий PHP сайт не работает
Цитата: misterX от 19 сентября 2017, 14:14:51у меня нет сайта
Или вы форум так называете? Подумал у вас там ещё и сайт есть.

Т.е., у вас на версии форума 2.0.13 с php 5.4 не работает форум? Быть такого не может, если так, то это косяк из-за каких-то мода(ов) может быть, тогда ищите этот мод (можете по логам вычислить, смотря на ошибки), удаляйте его, обновляйте версию php как минимум до 5.4 и после обновляйте форум.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

momorliss

Господа! Этот вопрос был решен?  У меня такая же проблема

GeorG

Цитата: momorliss от 06 ноября 2017, 01:47:50У меня такая же проблема
Какая именно и на каком шаге? Если ошибка подключения к БД, смотрите правильно ли вы указываете подключение к ней.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

misterX

Цитата: GeorG от 19 сентября 2017, 16:30:25Или вы форум так называете? Подумал у вас там ещё и сайт есть.

Т.е., у вас на версии форума 2.0.13 с php 5.4 не работает форум? Быть такого не может, если так, то это косяк из-за каких-то мода(ов) может быть, тогда ищите этот мод (можете по логам вычислить, смотря на ошибки), удаляйте его, обновляйте версию php как минимум до 5.4 и после обновляйте форум.


Всё таки этот косяк не даёт мне покоя)
Поддержка говорит:
"При смене версии PHP для Вашего сайта в логах наблюдаем ошибки:
.../.htaccess: ErrorDocument takes two arguments, Change responses for HTTP errors, referer: http://адрес сайта/index.php

Сайт корректно работает только при версии PHP 5.3."

GeorG

Читайте полный лог ошибки, там обычно пишется строка где ошибка происходит, там и ищите проблему.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

misterX

дело в том что за 2 месяца в логах ошибках набирается около 200тысяч ошибок и сложно понять с чем связана эта проблема  :(

GeorG

Зашли в админку, очистили логи, обновили страницу с темой, смотрите новые логи.


Цитата: misterX от 09 ноября 2017, 19:50:08./.htaccess: ErrorDocument takes two arguments, Change responses for HTTP errors, referer: http://адрес сайта/index.php
Вот с этим в гугл, это никак не относится к форуму.
Смотрите что у вас там в файле .htaccess вторым аргументом значится. Путь неправильно к документу указан.


Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru