Поддержка HTTP/2 + SSL?

Автор -ExotiC-, 17 июля 2017, 23:23:31

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

-ExotiC-

Форум работает (если зайти из поисковиков/в админку), но не открывается главная страница с такой ошибкой:
ЦитироватьCannot use string offset as an array

Ошибки в логах:
Код
Invalid argument supplied for foreach()
Файл: /forum/Themes/default/Errors.template.php (body_above sub template - eval?)
Строка: 452

Код
Parameter 1 to addQuickSpoilerBuffer() expected to be a reference, value given
Мод QuickSpoiler удалял. Не помогло.

Не зависит от выбранной теме. Главная страница форума не грузится ни на default, ни на core, ни на постоянной кастомной теме.
Хостинг SMF. Оплата только за использованные ресурсы.

kak2z

в функцию передалось значение, а должна была быть ссылка..
какой это спойлер?? можете ссылку на этот мод дать.. посмотрю что там.
Если нужно что то исправить, обновить, переставить, настроить, сделать форум заново - пишите в ЛС)

-ExotiC-

Цитата: kak2z от 17 июля 2017, 23:27:45в функцию передалось значение, а должна была быть ссылка..
какой это спойлер?? можете ссылку на этот мод дать.. посмотрю что там.
QuickSpoiler от Bugo http://custom.simplemachines.org/mods/index.php?mod=2940
Удаление не помогло. Т.е. мод удалился нормально, без ошибок, всё нужное за собой удалил, но главная форума так и не грузится.
Хостинг SMF. Оплата только за использованные ресурсы.

kak2z

Цитата: -ExotiC- от 17 июля 2017, 23:30:28QuickSpoiler от Bugo http://custom.simplemachines.org/mods/index.php?mod=2940
Удаление не помогло. Т.е. мод удалился нормально, без ошибок, всё нужное за собой удалил, но главная форума так и не грузится.
значит еще какой то мод мешает.. наверно сменили версию пхп?
Если нужно что то исправить, обновить, переставить, настроить, сделать форум заново - пишите в ЛС)

-ExotiC-

Цитата: kak2z от 17 июля 2017, 23:31:52значит еще какой то мод мешает.. наверно сменили версию пхп?
Да, переехал на другой хостинг. Стояла 7.x какая-то. Точно не могу сказать. Ныне стоит 7.1.5. Еще из изменений: теперь HTTP/2+SSL против обычного SSL.
UPD: И вправду, ошибка была из-за смены версии, большое спасибо. Поставил 7.0 обратно. Пока пусть хотя бы так работает :)
Хостинг SMF. Оплата только за использованные ресурсы.

kak2z

Цитата: -ExotiC- от 17 июля 2017, 23:34:14Да, переехал на другой хостинг. Стояла 7.x какая-то. Точно не могу сказать. Ныне стоит 7.1.5. Еще из изменений: теперь HTTP/2+SSL против обычного SSL.
UPD: И вправду, ошибка была из-за смены версии, большое спасибо. Поставил 7.0 обратно. Пока пусть хотя бы так работает :)
если посмотреть на логи сервера, то можно увидеть где ошибка.. если посмотрите - исправим)
Если нужно что то исправить, обновить, переставить, настроить, сделать форум заново - пишите в ЛС)

-ExotiC-

Цитата: kak2z от 17 июля 2017, 23:43:03если посмотреть на логи сервера, то можно увидеть где ошибка.. если посмотрите - исправим)
Shared хостинг к сожалению  :(
Логи были отключены в момент использования PHP 7.1.5 и ошибок. Не хочу снова переключать)
Хостинг SMF. Оплата только за использованные ресурсы.

kak2z

Код
Parameter 1 to addQuickSpoilerBuffer() expected to be a reference, value given
вот эта ошибка скорее всего повторится когда спойлер поставите..
Если нужно что то исправить, обновить, переставить, настроить, сделать форум заново - пишите в ЛС)

-ExotiC-

Цитата: kak2z от 18 июля 2017, 00:16:36
Код
Parameter 1 to addQuickSpoilerBuffer() expected to be a reference, value given
вот эта ошибка скорее всего повторится когда спойлер поставите..
Спойлер стоит, ошибки не вижу)
Хостинг SMF. Оплата только за использованные ресурсы.

-ExotiC-

Цитата: kak2z от 18 июля 2017, 00:16:36
Код
Parameter 1 to addQuickSpoilerBuffer() expected to be a reference, value given
вот эта ошибка скорее всего повторится когда спойлер поставите..
Каюсь, ошибка всё же появилась  :( Не знаю даже куда смотреть, чтоб исправить....
Хостинг SMF. Оплата только за использованные ресурсы.

InterVi

Тоже самое, приходится логирование отключать.

InterVi

22 августа 2017, 03:13:57 #11 Последнее редактирование: 22 августа 2017, 18:18:19 от InterVi
В общем, нашёл.
Код
function addQuickSpoilerBuffer($buffer)
Subs-QuickSpoiler.php, строка 113, убираем &

И да... это никак не связано с SSL.

Сан

InterVi, спасибо огромное!
Сам бы я никогда не нашёл такого.

Теперь не совсем по теме вопрос.
В коде рядом есть другие функции с таким значком в параметре типа
function addQuickSpoilerButtons(&$buttons)
Что с ними делать?

digger®

Цитата: Сан от 06 ноября 2018, 14:54:14InterVi, спасибо огромное!
Сам бы я никогда не нашёл такого.

Теперь не совсем по теме вопрос.
В коде рядом есть другие функции с таким значком в параметре типа
function addQuickSpoilerButtons(&$buttons)
Что с ними делать?
Можно, просто, мод обновить до актуальной версии, в которой это все исправлено и ничего вручную не делать.