Мод на репутацию - есть ли на 2.1 beta 2?

Автор Juanito, 12 Июль 2016, 13:46:20

« предыдущая тема - следующая тема »

0 Пользователей и 1 Гость просматривают эту тему.

Вниз

Juanito

Собственно, есть ли на 2.1 рабочий мод с репутацией? Ставил этот http://custom.simplemachines.org/mods/index.php?mod=1129, но не работает.


Juanito

Я вот сейчас вижу, что на этом форуме собственно карма включена. Кто-нибудь знает, какой тут мод стоит?)

GeorG

Тут вывод из БД старой кармы, которая выставлялась, когда форум был ещё на движке версии 2.0.

Кстати, почему бы не воткнуть сюда этот мод?
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

Juanito

Цитата: digger® от 12 Июль 2016, 14:18:45https://github.com/live627/smf-karma
Не знаю, насколько он рабочий.
"Устанавливаемый пакет поврежден или не совместим с используемой версией SMF. Попробуйте установить мод в режиме эмуляции."

Кстати, заодно. Что за режим эмуляции?

GeorG

Перепакуйте архив, чтобы установочные файлы были не в папке с названием мода, а сразу в архиве лежали.

ЦитироватьКстати, заодно. Что за режим эмуляции?
Это чтобы можно было устанавливать на разные версии форумов (в том случае если ошибок при этом не будет).
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

Serifa

версия форума 2.1
«- Помощник капитана Бакстер, - заявил Лумис, - безбожно врет. Все отнюдь не под контролем, вернее, не под его контролем. Корабль захвачен представителями небелковой формы разумной жизни, которые маскируются под обслуживающих роботов, а некоторые даже не делают и этого...»
«То, что у тебя есть, лечится антибиотиками» (nowhere man, 1995)
Yandex 41001731341714

digger®

Цитата: Juanito от 13 Июль 2016, 00:35:00"Устанавливаемый пакет поврежден или не совместим с используемой версией SMF. Попробуйте установить мод в режиме эмуляции."
Нужно в файле
package-info.xml

Код
<install for="2.1 - 2.1.99">
заменить на
Код
<install for="2.1 - 2.1.99, 2.1 Beta 2, 2.1 Beta 3">
и
Код
<uninstall for="2.1 - 2.1.99">
заменить на
Код
<uninstall for="2.1 - 2.1.99, 2.1 Beta 2, 2.1 Beta 3">

S.T.A.L.K.E.R.

#8
13 Июль 2016, 18:47:33 Последнее редактирование: 13 Июль 2016, 20:00:58 от S.T.A.L.K.E.R.
Мод стал и не работает.
В логах после удаления полно ошибки вида - Hook call: function "KarmaIntegration::admin_areas" in file  could not be called.
Абзац.Мод сырой и недоделан.

Villen

пытаюсь разобраться в моде (скачан по ссылке в первом ответе) на SMF2.1 beta 3.
Установка прошла без ошибок, но мод не работает

Начал с админки. Вижу проблему: при входе в настройки (sa=karma) выводятся настройки секции basic

локализовал причину:
1) в файле ManageSettings.php на 58 строке задается массив действий $subActions = array(
2) на 70 строке проверяется что sa входит в этот массив, иначе делаем действие basic
3) далее на 101 строке вызывается call_integration_hook , который добавляет новые действия.
Очевидно что 2 и 3 действия надо переставить местами.

В теперь вопрос.  как это сделать наиболее грамотно? чтоб не сломать логику работы других модификаций.

ps: продолжение следует.

valdnieks

Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

Villen

Это ж не то.
Лайки в 2.1 уже из коробки работают. А репутация может и в минус.

Да ладно с лайками с этими.
Я хочу разобраться в работе хуков
я вижу в ядре SMF ошибку в логике,  действия 2 и 3 поменяны местами.

digger®

Цитата: Villen от 30 Ноябрь 2018, 16:39:49локализовал причину:
1) в файле ManageSettings.php на 58 строке задается массив действий $subActions = array(
2) на 70 строке проверяется что sa входит в этот массив, иначе делаем действие basic
3) далее на 101 строке вызывается call_integration_hook , который добавляет новые действия.
Очевидно что 2 и 3 действия надо переставить местами.

В теперь вопрос.  как это сделать наиболее грамотно? чтоб не сломать логику работы других модификаций.
Взять актуальную версию SMF 2.1 с гитхаба, вместо кривой беты двухлетней давности.

Villen

Хорошо, посмотрю гитхаб.

вопрос , почему ее нет на download.simplemachines.org ?
это уже офтоп, ткните где происходит обсуждение beta4 ?


Villen

на этом форуме принято отвечать не то что спрашивают?

S.T.A.L.K.E.R.

Цитата: Villen от 01 Декабрь 2018, 18:52:46на этом форуме принято отвечать не то что спрашивают?
А что Вы спрашивали?
Что спросили то и ответили.
Все вопросы по поводу 2.1 бета лучше сразу на гитхаб разработчикам адресовать.Тут разработчиков нет.

Villen

я спросил почему бетта 4 не выложена на официальном сайте, а только на гитхабе?
и также где обсуждение этот версии *на этом* форуме.
Если мне интересны были бы другие форумы, я бы спросил там.
Непонятно только зачем нужен этот.

S.T.A.L.K.E.R.

Цитата: Villen от 02 Декабрь 2018, 01:42:20я спросил почему бетта 4 не выложена на официальном сайте, а только на гитхабе?
Это знают только на официальном сайте
Цитата: Villen от 02 Декабрь 2018, 01:42:20и также где обсуждение этот версии *на этом* форуме.
В этой ветке,Вы уже обсуждаете :)
Похоже Вы пока единственный,кто её обсуждает.
На самом деле пользователей 2.1 в разной стадии бет не так уже и много,в силу её глючности,сырости и недоделанности.Код от беты к бете временами кардинально меняется.Кому охота ходить по минному полю ???
Я почти три года тому назад ставил,потом избавился.На рабочие проекты ставить не рекомендую.

digger®

Цитата: Villen от 02 Декабрь 2018, 01:42:20я спросил почему бетта 4 не выложена на официальном сайте, а только на гитхабе?
Потому, что релиза такой версии никогда не было и уже не будет.

Цитироватьи также где обсуждение этот версии *на этом* форуме.
Нигде, потому что такого релиза не существует, соответственно нечего обсуждать.

ЦитироватьЕсли мне интересны были бы другие форумы, я бы спросил там.
Непонятно только зачем нужен этот.
Если у вас интерес к unstabe ветке в которой за неделю может быть сотня коммитов в которых одно починят, другое поломают, то issues на github самое подходящее место.

S.T.A.L.K.E.R.

Цитата: digger® от 02 Декабрь 2018, 21:50:10Потому, что релиза такой версии никогда не было и уже не будет.
В смысле бета4 релиза не будет? Что случилось тогда?
Или релиза того текущего что на гите?


donfisher

Цитата: digger® от 02 Декабрь 2018, 23:00:12Ближайшим релизом планируется RC1
По срокам выхода, есть какая нибудь информация, хотя бы на уровне слухов?

Hatshepsut


Mavn

SimpleMachines Russian Community Team
п.1 Пройду курсы гадалок для определения исходного кода по скриншоту.
п.2 Сервис бесплатных форумов
Каталог форумов SMF

п.3 У вас нет желания читать правила раздела, у меня нет желания одобрять темы, которые не соответствуют этим правилам.

Villen

однако версия с гитхаба определяется как бета 4.
почему ее нет в релизах отдельный вопрос и похоже никто не знает на него ответ.

и почему обсуждение продожается в теме мода репутации?
тут модерация вообще существует?

S.T.A.L.K.E.R.

Цитата: Villen от 07 Декабрь 2018, 10:43:12однако версия с гитхаба определяется как бета 4.
почему ее нет в релизах отдельный вопрос и похоже никто не знает на него ответ.
На гитхабе правки и релизы практически каждый день. Все их официально представлять заморишься просто
Цитата: Villen от 07 Декабрь 2018, 10:43:12и почему обсуждение продожается в теме мода репутации?
Так,обсуждать то толком и нечего. Большинство на единице или двойке сидят. А что до 2.1 - по началу указывали срок выхода финальной версии как 2021,сейчас по моему отодвинули на 2025. Если не позже.
А обсужать текущее на гитхабе не интересно. Сегодня там одно,через неделю может быть уже совсем другое

Villen

а кто говорит что гитхаб надо релизить практически каждый день.
Но постойте ,  когда вышла бета 3 ? ктот омне сказал что 2 года прошло уже.
можно было бы и зарелизить beta 4 и дальше пилить "ночные" версии.

Что по поводу все сидят на 2ке , я еще на 1.1
но перезжать на 2.0 не хочется, преимущесва 2.1 слишком явно заметны.
Сырости и кривости уже осталось очень мало, следущий же RС планировался
т.е стабильная версия очень-очень близко.
 

S.T.A.L.K.E.R.

А в чем явные преимущества 2.1 перед единицей?

Villen

единица не запустится на php7.0
нужно много переписыввать , практически весь класc mysql
может это и не так сложно, отличия mysql и mysqli не такие огромные
ельфчат я, можно сказать, удачно портировал на mysqli  (и оно рабоатет на php7.0)

А началось все с идеи перехать с sharing хостинга на vps. Но не ставить же на него древний php5.3?
По умолчанию там ставится 7.0.10, ну я запустил инсталятор smf2.0.15 и обнаружил что форум установился без проблем.
Далее, наличие устаревших конструкций в коде smf2.0 заставило посмотреть на smf2.1 и он оказался лучше по многим параметрам:
лучше верстка, лучше реализованы отладочные функции.


В тоже время нельзя сказать что 1.1.16 версия устарела так, что ей невозможно пользоваться. Просто думаю пора наконец обновиться.


S.T.A.L.K.E.R.

А профит от использования php7, избавления от устаревших конструкций и все остального?
И зачем на VPS 5.3php юзать если можно с таким же успехом 5.6 использовать?

Вверх