Выпущены обновления SMF 2.0.16 и 2.0.17

Автор digger®, 29 Декабрь 2019, 05:13:43

« назад - далее »

0 Пользователей и 1 гость просматривают эту тему.

Delysid

Цитата: S.T.A.L.K.E.R. от 08 Январь 2020, 22:41:42Я понял,тоже сегодня смотрел.Выше так же скрин сделал.
Там если открыть отчёт.. То дата когда он последний раз сделан...
Последнее обновление у меня 07.01.2020, пошёл проверять весь код 2.0.16 и искать есть ли где задержки.

S.T.A.L.K.E.R.

Цитата: Delysid от 08 Январь 2020, 22:55:10Там если открыть отчёт.. То дата когда он последний раз сделан...
Смотрел,открывал.0,проблем нет
Цитата: Delysid от 08 Январь 2020, 22:55:10Последнее обновление у меня 07.01.2020,
Точно так же - Последнее обновление: 07.01.2020

Delysid

:facepalm:
Это не ошибка. Клоудфларе показывает:
First Interactive
Mobile (3G) 5.2 s
Desktop (Cable) 1 s
Что то по мобильным сильно ударило обновление.. Что делать не знаю.. Так гугл в поиске отбросит..
Сегодня я расстроен, какой не справедливый мир.. Ушёл.

S.T.A.L.K.E.R.

Часть модов перестало работать. Некоторые полностью. Моды очень нужны, вечером буду откатываться и на этом с обновлениями баста.

valdnieks

Можно устанавливать с ошибками?
Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

S.T.A.L.K.E.R.

Цитата: valdnieks от 10 Январь 2020, 14:47:29Можно устанавливать с ошибками?
Если есть желание к тем ошибкам и глюкам что у Вас уже есть добавить ещё глюков и багов то да,можно.
Цитата: Delysid от 08 Январь 2020, 23:05:34:facepalm:
Сегодня я расстроен, какой не справедливый мир.. Ушёл.
Откатился обратно на крайний свой последний бекап.Что там была за версия уже и не помню,или 14 или 15.
Главное что работает стабильно уже больше двух лет,пускай так далее и работает.С обновами завязал окончательно.

valdnieks

Цитата: S.T.A.L.K.E.R. от 10 Январь 2020, 20:02:45Если есть желание к тем ошибкам и глюкам что у Вас уже есть добавить ещё глюков и багов то да,можно.

Каждый день что-то с форумом происходит в 03:00. Ошибки появляются или исчезают. Например, load.php, портал изменился.
Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

Delysid

Цитата: S.T.A.L.K.E.R. от 10 Январь 2020, 20:02:45Если есть желание к тем ошибкам и глюкам что у Вас уже есть добавить ещё глюков и багов то да,можно.Откатился обратно на крайний свой последний бекап.Что там была за версия уже и не помню,или 14 или 15.
Главное что работает стабильно уже больше двух лет,пускай так далее и работает.С обновами завязал окончательно.
Я откатываться не буду.. Не большой смысл для меня если я потеряю в поисковиках позиции - всё равно сообщество знает про сайт и он на донатах выкарабкивается.
Как не странно у меня все моды работают и нету ошибок.
Я нашёл почему позиции упали на мобильных. В патче что то делали с выводом аватара и proxy и
к изменению что патчит 2.0.16 гугл начал плюсовать время вызова на отображения аватара..
Буду надеется что перепроверит. Хотя походу бесполезно...

S.T.A.L.K.E.R.

Цитата: Delysid от 11 Январь 2020, 09:19:34Я откатываться не буду.. Не большой смысл для меня если я потеряю в поисковиках позиции - всё равно сообщество знает про сайт и он на донатах выкарабкивается.
Как не странно у меня все моды работают и нету ошибок.
Я в принципе разобрался со всем,там у меня перестало работать именно из-за введения GDPR.Немного поправил то что не работало и всё взлетело.Пока обкатываю на тестовом,если будет нормально то перенесу изменения на основной.
Цитата: Delysid от 11 Январь 2020, 09:19:34В патче что то делали с выводом аватара и proxy и
к изменению что патчит 2.0.16
Проксирование меняли это точно.За аватарки не смотрел
Цитата: Delysid от 11 Январь 2020, 09:19:34гугл начал плюсовать время вызова на отображения аватара..
А вот у меня аватарки лежат в отдельной папке может по этому у меня по графику всё нормально...

Delysid

Цитата: S.T.A.L.K.E.R. от 11 Январь 2020, 13:20:41Я в принципе разобрался со всем,там у меня перестало работать именно из-за введения GDPR.Немного поправил то что не работало и всё взлетело.Пока обкатываю на тестовом,если будет нормально то перенесу изменения на основной.Проксирование меняли это точно.За аватарки не смотрелА вот у меня аватарки лежат в отдельной папке может по этому у меня по графику всё нормально...
Так у меня тоже отдельно. Походу разница в том что у меня притормаживание с дополнительными запросами index.php?action=dlattach;attach=XXX;type=avatar, как сменил патч и что то поменялось и гугл это словил и задетектил для мобильных ухудшение..
Но после такого чтения я в 2.1 не ногой  2funny  https://github.com/SimpleMachines/SMF2.1/issues/5734
я представляю, что тут надо будет VPS покупать за 80 баксов в месяц чтобы всё быстро работало и не выпадало из поиска гугла...  ;D

S.T.A.L.K.E.R.

Пока удалось подружить всё,разобрался что к чему,отвалился мод на хуках и мод пришлось править
Осталось только дождаться фикса для очистки лога,разобрался я и там и уже и правки опробовал.Но лезть и ставить костыль пока не охота.Дождусь официального фикса.

Delysid

Цитата: S.T.A.L.K.E.R. от 11 Январь 2020, 17:29:06Пока удалось подружить всё,разобрался что к чему,отвалился мод на хуках и мод пришлось править
Осталось только дождаться фикса для очистки лога,разобрался я и там и уже и правки опробовал.Но лезть и ставить костыль пока не охота.Дождусь официального фикса.


Я ничего не жду.. Как маркетолог могу сказать, что будет последний патч после которого навряд ли будут
обновления. Очень открыто всё видно, что разработчики намереваются всех согнать на 2.1 и этот
последний патч будет мостом для 2.1 и потом всё.
Ой, что будет что будет.. Будет страшный хайп когда начнётся переход кто в PHP не понимает на 2.1,
будет куча патчей и эксплоитов..  ;D  Я отсижусь по возможности до окончания возможности работы 2.0 на PHP 7.4  :)
И подожду когда сможет работать 2.1 в PHP 7.5  :)

S.T.A.L.K.E.R.

Цитата: Delysid от 11 Январь 2020, 18:21:07Ой, что будет что будет.. Будет страшный хайп когда начнётся переход кто в PHP не понимает на 2.1,
А зачем переходить вообще?Мне если честно годами и на 2.0.15 было замечательно.
Не планирую вообще никуда тыкаться.

istambulz

Добрый день. Можно ли обновиться обратно с 2.0.17 на 2.0.15 ? После обновления на 2.0.17, не могу зайти под своим ником, нажимаю даже на забыли пароль ? Меняю пароль по почте, и все равно не заходит на форум! 

Delysid

Цитата: S.T.A.L.K.E.R. от 11 Январь 2020, 18:41:25А зачем переходить вообще?Мне если честно годами и на 2.0.15 было замечательно.
Не планирую вообще никуда тыкаться.

В общем у меня качели на грани.. Придётся оптимизировать загрузку скриптов.  :-\

Delysid

Цитата: istambulz от 13 Январь 2020, 16:55:55Добрый день. Можно ли обновиться обратно с 2.0.17 на 2.0.15 ? После обновления на 2.0.17, не могу зайти под своим ником, нажимаю даже на забыли пароль ? Меняю пароль по почте, и все равно не заходит на форум!
Ввели дополнительные куки.. На оф. форуме тема есть, мол у кого не входит нужно прописать принудительно в скрипт параметр дающий работать по старому. К сожалению нету в закладке этой темы..

istambulz

Цитата: Delysid от 14 Январь 2020, 23:59:39Ввели дополнительные куки.. На оф. форуме тема есть, мол у кого не входит нужно прописать принудительно в скрипт параметр дающий работать по старому. К сожалению нету в закладке этой темы..
Подскажите пожалуйста что за скрипт, и куда его вставлять! Заранее спасибо!

Delysid

Цитата: istambulz от 17 Январь 2020, 00:13:06Подскажите пожалуйста что за скрипт, и куда его вставлять! Заранее спасибо!
На официальном форуме simplemachines.org есть статья про дополнительные куки в последних патчах и там написано, что делать и куда и какую строку поменять в скрипте чтобы куки работали по старому... В закладке у меня этой статьи нету, мне искать также как и вам.

istambulz

Цитата: Delysid от 17 Январь 2020, 04:20:47На официальном форуме simplemachines.org есть статья про дополнительные куки в последних патчах и там написано, что делать и куда и какую строку поменять в скрипте чтобы куки работали по старому... В закладке у меня этой статьи нету, мне искать также как и вам.
Не получается найти. Может быть кто то уже исправлял этот случай ?

Delysid

18 Январь 2020, 18:15:14 #69 Последнее редактирование: 27 Январь 2020, 20:00:38 от digger®
Цитата: istambulz от 18 Январь 2020, 00:34:19Не получается найти. Может быть кто то уже исправлял этот случай ?
https://www.simplemachines.org/community/index.php?topic=570989.0

Farabundo

Цитата: S.T.A.L.K.E.R. от 11 Январь 2020, 18:41:25А зачем переходить вообще?Мне если честно годами и на 2.0.15 было замечательно.
Не планирую вообще никуда тыкаться.

Здравствуйте, я не профессиональный админ, до определённого времени мне помогали с администрированием, потом остался один. Пользовался подсказками, подсмотренными здесь, апнулся в итоге до 2.0.15. (есть моды) и тоже жил, не тужил.

Почитав о проблемах с 2.0.16. и 2.0.17., с радостью остался бы на 2.0.15., но последнее время в логах горы ошибок и форум раз в неделю падает, ошибка "Table './r0069996_smfdb/usmf_messages' is marked as crashed and last (automatic?) repair failed". Проверка базы всё мгновенно восстанавливает, но хотелось бы попросить подсказки у более продвинутых в SMF - в чём может быть проблема, и как справиться?

S.T.A.L.K.E.R.

Цитата: Farabundo от 13 Февраль 2020, 23:05:20Почитав о проблемах с 2.0.16. и 2.0.17., с радостью остался бы на 2.0.15., но последнее время в логах горы ошибок и форум раз в неделю падает, ошибка "Table './r0069996_smfdb/usmf_messages' is marked as crashed and last (automatic?) repair failed". Проверка базы всё мгновенно восстанавливает, но хотелось бы попросить подсказки у более продвинутых в SMF - в чём может быть проблема, и как справиться?
БД большая?

Farabundo



Farabundo

Цитата: digger® от 15 Февраль 2020, 22:51:35Посмотрите записи в логе mysql, что то наверняка происходит в том момент из-за чего таблица бьется.
Спасибо, когда это произойдёт в следующий раз, сделаю и отпишу.