Проблема со ссылками в админке !!!

Автор Deesare, 18 апреля 2010, 19:49:35

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

Deesare

Версия форума: SMF 2.0 RC1.2
тема оформления brightforest_22
У меня возникла проблема при установке вышеуказанной темы оформления ссылки имеют вид
мой_сайт.ru/;area=index;dc169e48=16aa21e837e29c0cc45229d072196a7b в место положенного
мой_сайт.ru/index.php?action=admin;area=index;dc169e48=16aa21e837e29c0cc45229d072196a7b
Я человек не местный помогите кто чем может...  :'(  :'(  :'(
Ненавижу две вещи - Расизм и негров

Drakonsa


Deesare

нет не чего больше не установлено
Ненавижу две вещи - Расизм и негров

Mavn

ну так обновитесь до последней версии и проблема решится!!
SimpleMachines Russian Community Team
п.1 Пройду курсы гадалок для определения исходного кода по скриншоту.

п.2 У вас нет желания читать правила раздела, у меня нет желания одобрять темы, которые не соответствуют этим правилам.

Deesare

Ненавижу две вещи - Расизм и негров

Bugo


Deesare

всем спасибо пока ждал помощь сам разобрался
Ненавижу две вещи - Расизм и негров

djbob2000

Не стал создавать новую тему, решил написать тут: не заметил на каком этапе, но перестали работать некоторые ссылки в админке, белый лист ошибка 500:
Основные настройки
Характеристики и настройки
Безопасность и модерирование
Настройки модов

Всё остальное работает.

Установлены:
1.   SMF 2.0.2 Update   1.0
2.   Aeva ~ Auto-Embed Video & Audio   7.1
3.   SMF 2.0.1 Update   1.0
4.   RedirectPage   1.9b
5.   Ad Managment   3.0.1
6.   Counters: Google, StatCounter & Yandex   1.0a
7.   Users Online Today   1.6.0
8.   KeyCAPTCHA for SMF   2.1
9.   Kolobok smiles for light SMF theme   1.0

Куда копать? Что проверить? Вообще непонимаю почему именно некоторые не работают.

maestrosite.ru

Цитата: djbob2000 от 05 апреля 2012, 15:09:33
Не стал создавать новую тему, решил написать тут: не заметил на каком этапе, но перестали работать некоторые ссылки в админке, белый лист ошибка 500:
Основные настройки
Характеристики и настройки
Безопасность и модерирование
Настройки модов

Всё остальное работает.

Установлены:
1.   SMF 2.0.2 Update   1.0
2.   Aeva ~ Auto-Embed Video & Audio   7.1
3.   SMF 2.0.1 Update   1.0
4.   RedirectPage   1.9b
5.   Ad Managment   3.0.1
6.   Counters: Google, StatCounter & Yandex   1.0a
7.   Users Online Today   1.6.0
8.   KeyCAPTCHA for SMF   2.1
9.   Kolobok smiles for light SMF theme   1.0

Куда копать? Что проверить? Вообще непонимаю почему именно некоторые не работают.

Копайте логи. Проверяйте найденные ошибки.
Если задаются вопросы по вашей проблеме, значит это нужно вам!
---
Обновления форума, разрешение конфликтов, адаптация модов, исправление ошибок - ваши предложения о сотрудничестве направляйте по адресу smf@maestrosite.ru

djbob2000

Логи чего? В логах форума ничего нет, мало того если нажимаю "Очистка логов" тоже белая страница.
Единственное что нашел - устаревший файл PersonalMessage.template.php от версии 2.0. Но это же не в нем проблема.

maestrosite.ru

Цитата: djbob2000 от 05 апреля 2012, 15:45:31
Логи чего? В логах форума ничего нет, мало того если нажимаю "Очистка логов" тоже белая страница.
Единственное что нашел - устаревший файл PersonalMessage.template.php от версии 2.0. Но это же не в нем проблема.

Когда ошибка 5xx, первым делом смотрите логи апача. Так как такая ошибка говорит скорее всего о синтаксической ошибке, попытке подключения отсутствующего файла, либо попытке повторного определения функции.

upd
У вас точно SMF 1.1 ?
Если задаются вопросы по вашей проблеме, значит это нужно вам!
---
Обновления форума, разрешение конфликтов, адаптация модов, исправление ошибок - ваши предложения о сотрудничестве направляйте по адресу smf@maestrosite.ru

djbob2000

Ой ой извините, у меня 2.0.2 Я просто поиском искал, куча тем перечитывал, запутался.
Посмотрел логи. Абсолютно ничего нет. Может запись логов где-то выключена?

maestrosite.ru

05 апреля 2012, 16:37:19 #12 Последнее редактирование: 05 апреля 2012, 16:51:07 от maestrosite.ru
Цитата: djbob2000 от 05 апреля 2012, 16:25:19
Ой ой извините, у меня 2.0.2 Я просто поиском искал, куча тем перечитывал, запутался.
Посмотрел логи. Абсолютно ничего нет. Может запись логов где-то выключена?

Странно, конечно, что логи пустые. Включены/выключены логи апача - это в панель хостинга или к хостеру. "Снаружи" можно только гадать

upd
Судя по всему, покорёжен у вас /Source/ManageSettings.php
Если задаются вопросы по вашей проблеме, значит это нужно вам!
---
Обновления форума, разрешение конфликтов, адаптация модов, исправление ошибок - ваши предложения о сотрудничестве направляйте по адресу smf@maestrosite.ru

digger®

Цитата: djbob2000 от 05 апреля 2012, 16:25:19Ой ой извините, у меня 2.0.2 Я просто поиском искал, куча тем перечитывал, запутался.Посмотрел логи. Абсолютно ничего нет. Может запись логов где-то выключена?

Проверьте, что у вас в базе таблица smf_log_errors имеется и она не битая.

djbob2000

maestrosite.ru, Вы оказались правы! Поглядел, в панели таки нашел где включить ошибки записывать. Пишет апач:

[Thu Apr 05 18:17:33 2012] [warn] mod_fcgid: stderr: PHP Fatal error:  Cannot redeclare modifyaevasettings() (previously declared in /home/xxxx/forum/Sources/ManageSettings.php:2098) in /home/xxxx/forum/Sources/ManageSettings.php on line 2199

В 2098 строке
Код

/ Aeva - START
function ModifyAevaSettings($return_config = false)
{
global $sourcedir;
[at]require_once($sourcedir .'/Subs-Aeva-Admin.php');
return aeva_admin_manager($return_config, isset($_GET['sa']) ? $_GET['sa'] : '');
}
// Aeva - END


В 2199 строке:
Код

// Aeva - START
function ModifyAevaSettings($return_config = false)
{
global $sourcedir;
[at]require_once($sourcedir .'/Subs-Aeva-Admin.php');
return aeva_admin_manager($return_config, isset($_GET['sa']) ? $_GET['sa'] : '');
}
// Aeva - END


Удалил Aeva - всё заработало. В чем тут у них косяк? Я в пхп не особо мастер:)

maestrosite.ru

05 апреля 2012, 19:47:51 #15 Последнее редактирование: 06 апреля 2012, 09:49:55 от maestrosite.ru
Цитата: djbob2000 от 05 апреля 2012, 19:32:19
maestrosite.ru, Вы оказались правы! Поглядел, в панели таки нашел где включить ошибки записывать. Пишет апач:

[Thu Apr 05 18:17:33 2012] [warn] mod_fcgid: stderr: PHP Fatal error:  Cannot redeclare modifyaevasettings() (previously declared in /home/xxxx/forum/Sources/ManageSettings.php:2098) in /home/xxxx/forum/Sources/ManageSettings.php on line 2199


Видимо остались хвосты от предыдущей установки аевы, либо некорректный установщик. Посмотрите после удаления, если одна из функций осталась, значит предыдущая установка не была удалена корректно и есть хвосты.
Если задаются вопросы по вашей проблеме, значит это нужно вам!
---
Обновления форума, разрешение конфликтов, адаптация модов, исправление ошибок - ваши предложения о сотрудничестве направляйте по адресу smf@maestrosite.ru

Mavn

Цитата: djbob2000 от 05 апреля 2012, 15:45:31
Логи чего? В логах форума ничего нет, мало того если нажимаю "Очистка логов" тоже белая страница.
Единственное что нашел - устаревший файл PersonalMessage.template.php от версии 2.0. Но это же не в нем проблема.

логи апача ковырять нужно ибо без них нельзя понять из за чего проблема у вас
SimpleMachines Russian Community Team
п.1 Пройду курсы гадалок для определения исходного кода по скриншоту.

п.2 У вас нет желания читать правила раздела, у меня нет желания одобрять темы, которые не соответствуют этим правилам.

djbob2000

Моя проблема решена, действительно остались хвосты от AEVA в файле /Sources/ManageSettings.php. После удаления хвостов всё заработало как надо.
Спасибо всем, особенно maestrosite.ru!