Выпущено обновление SMF 2.0.14

Автор digger®, 15 Май 2017, 01:01:19

« назад - далее »

0 Пользователи и 1 Гость просматривают эту тему.

kak2z

кстати...
а почему в Settings.php стоит
Код
$db_type = 'mysql';
а скрипт упорно вызывает mysqli функции?
Если нужно что то исправить, обновить, переставить, настроить, сделать форум заново - пишите в ЛС)

S.T.A.L.K.E.R.

15 Май 2017, 21:36:01 #51 Последнее редактирование: 15 Май 2017, 21:49:37 от S.T.A.L.K.E.R.
Цитата: digger® от 15 Май 2017, 21:11:20В файле ошибка, оператор exit зачем то заменен на переменную $exit. Как минимум, будет в лог валить про undefined var.
Честно,замена чисто интуитивная и всё работает - логи чистые как форумные так и апача...
При родном файле что идёт с обновлением при первоначальной загрузке у картинок ошибка 404,после обновления страницы они подгружаются.Я так понимаю что решения этой проблемы и на оффе не знают,пока использую как костыль и жду решения тут - https://www.simplemachines.org/community/index.php?topic=553875.msg3925882#new - кстати топик уже кто-то пометил как решенный хотя это не так.
Для мене если честно не критично,главное что работает как нужно.Можно и файл от беты 3 2.1 подсунуть.Он тоже работает.
Я для себя в файле пометку сделал что это костыль и при решении надо будет исправить.
Цитата: kak2z от 15 Май 2017, 21:11:35кстати...
а почему в Settings.php стоит
Код
$db_type = 'mysql';
а скрипт упорно вызывает mysqli функции?
А вот это надо пологать вторая моя ошибка.Решения на оффе тоже пока нет.Отключил пока как времянку вывод ошибок в файле,сыпет из
PHP Warning:  mysqli_select_db() expects parameter 1 to be mysqli, resource given in /Sources/Subs-Db-mysql.php on line 826
   
Код
public function select($database, $connection = null)
{
global $db_connection;

==> return mysqli_select_db($connection === null ? $db_connection : $connection, $database);
}
Кстати эта же ошибка была и в 2.1 постояно,вот её и 2.0.14 притянули.
За исключением этого всё штатно и нормально.Дождусь фиксов на оффе и поправлю потом.
На оффе уже зарекаются что это последнее обновление для 2.0 - больше обновлений не будет.

digger®

Цитата: valek0972 от 15 Май 2017, 19:20:33Да, стоит версия 2.0.1, попробовал обновиться, установился и белая страница.
Проверил TopFirstPost 2.0.4 на SMF 2.0.14 и PHP 7.0 - работает без проблем.

S.T.A.L.K.E.R.

Просматриваю на оффе - там тоже в полку - обновился и упал в ошибку 500 прибывает таки серьёзно.

gorbi

Судя по тамошним обсуждениям php 5.3 мимо кассы. Я перешёл на 5.6, но с 2.0.14 решил подождать пока допилится мод Social Login, а возможно всплывёт что-то ещё.

Интересно послушать оценку ситуацию гурой Диггером, если у него есть желание.

Snow_Irbis

Цитата: gorbi от 16 Май 2017, 09:31:05Судя по тамошним обсуждениям php 5.3 мимо кассы. Я перешёл на 5.6, но с 2.0.14 решил подождать пока допилится мод Social Login, а возможно всплывёт что-то ещё.

Тоже версия 5.3, вот видимо и нашли причину



Интересует такой вопрос, если переключиться на более новую версию php то не должно возникнуть никаких проблем? И на какую лучше переключиться, на 5.6 или на 7?

S.T.A.L.K.E.R.

Цитата: Snow_Irbis от 16 Май 2017, 12:14:15Тоже версия 5.3, вот видимо и нашли причину



Интересует такой вопрос, если переключиться на более новую версию php то не должно возникнуть никаких проблем? И на какую лучше переключиться, на 5.6 или на 7?
Пока до обновления до 5.6
После обновления до 2.0.14 можно и на 7,хотя судя по саппорту у людей проблемы и на 7 возникают+не все моды будут работать с 7.

ALINA

Цитата: Snow_Irbis от 16 Май 2017, 12:14:15Тоже версия 5.3, вот видимо и нашли причину
у меня версия 5.6 ,та же байда .И судя по индикации ( зеленый значок) устаревших версий модов нет.

Snow_Irbis

Цитата: ALINA от 16 Май 2017, 13:50:40у меня версия 5.6 ,та же байда .И судя по индикации ( зеленый значок) устаревших версий модов нет.

То есть и на 5.6 вызывает ошибку 500 как на скриншоте?



Хорошо что я тоже решил подождать с установкой обновы, а то второй раз восстанавливать с бекапа у меня валидола не хватит ;D

digger®

Цитата: ALINA от 16 Май 2017, 13:50:40у меня версия 5.6 ,та же байда .И судя по индикации ( зеленый значок) устаревших версий модов нет.
Этот значок ничего не говорит о старости установленных модов.

S.T.A.L.K.E.R.

16 Май 2017, 14:15:01 #60 Последнее редактирование: 16 Май 2017, 14:42:19 от S.T.A.L.K.E.R.
Цитата: Snow_Irbis от 16 Май 2017, 14:08:03То есть и на 5.6 вызывает ошибку 500 как на скриншоте?
Она ещё не ставила обнову.Ошибки как и у всех - три из-за редиректа мода.
И одна не дефолтная тема.
С проксироанием вроде как разрулили на саппорте - надежда такая есть.
Пока всё.

Snow_Irbis

Цитата: S.T.A.L.K.E.R. от 16 Май 2017, 14:15:01Она ещё не ставила обнову.Ошибки как и у всех - три из-за редиректа мода.
И одна не дефолтная тема.

Так в том то и дело что у меня при предыдущей установке никаких ошибок не светило, просто форум пошел на обеденный перерыв и все. Вот теперь после изменения версии php думаю подождать еще немного времени (может исправят ошибки) или накатить обнову еще раз :) ?

S.T.A.L.K.E.R.

Цитата: Snow_Irbis от 16 Май 2017, 14:25:55Так в том то и дело что у меня при предыдущей установке никаких ошибок не светило, просто форум пошел на обеденный перерыв и все. Вот теперь после изменения версии php думаю подождать еще немного времени (может исправят ошибки) или накатить обнову еще раз :) ?
Ну если что бекап сделать всех файлов что изменяет обновление.И пробывать
На саппорте у многих ошибка 500.И в основном вопрос сразу - версия РНР в панели?

S.T.A.L.K.E.R.

16 Май 2017, 18:26:30 #63 Последнее редактирование: 16 Май 2017, 18:47:27 от S.T.A.L.K.E.R.
Цитата: gorbi от 16 Май 2017, 09:31:05Я перешёл на 5.6, но с 2.0.14 решил подождать пока допилится мод Social Login, а возможно всплывёт что-то ещё.
Проверил только что на на 7.0.17 - работает - но моды переделывать нужно.
При входе в админку белая страница...
Это так,для примера.
Код
Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /my_recent_topics/recent_topics.php:5 Stack trace: #0 {main} thrown in /my_recent_topics/recent_topics.php on line 5
На 7.1.13 - толком не заработал форум.
Хоть на сервере и прикрутил 7 PHP прийдется ждать пока моды подтянутся и их переделают.Или новые схожие моды появятся которые будут работать на 7....

kak2z

Цитата: S.T.A.L.K.E.R. от 16 Май 2017, 18:26:30Проверил только что на на 7.0.17 - работает - но моды переделывать нужно.
При входе в админку белая страница...
Это так,для примера.
Код
Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /my_recent_topics/recent_topics.php:5 Stack trace: #0 {main} thrown in /my_recent_topics/recent_topics.php on line 5
На 7.1.13 - толком не заработал форум.
Хоть на сервере и прикрутил 7 PHP прийдется ждать пока моды подтянутся и их переделают.Или новые схожие моды появятся которые будут работать на 7....

в пхп 7 удалили библиотеку mysql... не будет работать..
Если нужно что то исправить, обновить, переставить, настроить, сделать форум заново - пишите в ЛС)

gorbi

Мне ответили из Social Login, они работают на 2.0.14. O0

S.T.A.L.K.E.R.

Цитата: kak2z от 16 Май 2017, 19:14:04в пхп 7 удалили библиотеку mysql... не будет работать..
Да там косяков хватает,причем не только с модами.Некоторые формы отображение их задваивается,отображение вложений тоже задваивается.Там саппорту ещё пилить и пилить,как минимум до 2.30 :)
Или уже забить на 2.0 на этой стадии как она сейчас есть и 2.1 до ума довести наконец-то.
Переключился с 7.0.17 обратно на 5.6.30 и не заморачиваюсь пока,ещё как минимум пару лет.

gorbi

Цитата: S.T.A.L.K.E.R. от 16 Май 2017, 19:37:02Да там косяков хватает,причем не только с модами.Некоторые формы отображение их задваивается,отображение вложений тоже задваивается.Там саппорту ещё пилить и пилить,как минимум до 2.30 :)
Или уже забить на 2.0 на этой стадии как она сейчас есть и 2.1 до ума довести наконец-то.
Переключился с 7.0.17 обратно на 5.6.30 и не заморачиваюсь пока,ещё как минимум пару лет.
Задваивание то такое, можно и допилить. Это не белый экран и восстановление из бекапа.
Вопрос по существу - а так определить а какой релиз патча выложен? Я так понимаю, правки они вносят.

S.T.A.L.K.E.R.

Цитата: gorbi от 16 Май 2017, 19:46:24Задваивание то такое, можно и допилить. Это не белый экран и восстановление из бекапа.
Там не только оно...
Цитата: gorbi от 16 Май 2017, 19:46:24Вопрос по существу - а так определить а какой релиз патча выложен? Я так понимаю, правки они вносят.
Ну если не указанно то наверно никак..

S.T.A.L.K.E.R.

Может кому перевод пригодится.
languages/ManageSettings.russian-utf8.php
Код
$txt['image_proxy_enabled'] = 'Включить кеширование изображений';
$txt['image_proxy_enabled_desc'] = 'Это будет кешировать изображения, размещенные в тегах <b> [img] </b>. </b>';
$txt['image_proxy_secret'] = 'Пароль прокси-сервера';
$txt['image_proxy_secret_desc'] = 'Пароль должен быть уникальным для вашего сайта. Не забудьте сохранить этот пароль в тайне. ';
$txt['image_proxy_maxsize'] = 'Максимальный размер файла для кэширования';
$txt['image_proxy_maxsize_postinput'] = 'KB';
$txt['image_proxy_maxsize_desc'] = 'Изображения выше этого порога не будут кешироваться.';
languages/Help.russian-utf8.php
Код
$helptxt['image_proxy_enabled'] = 'Включение кеширования изображений';
$helptxt['image_proxy_secret'] = 'Держите этот пароль в секрете, он защищает ваш форум от хотлинка. Измените его, чтобы изменить ссылки и сделать текущие ссылки хотлинка бесполезными ';
$helptxt['image_proxy_maxsize'] = 'Максимальный размер изображения, которое прокси-сервер будет кешировать: изображения больше этого размера кэшироваться не будут. Кэшированные изображения хранятся в папке кэша SMF, поэтому проверьте достаточно ли у Вас свободного места для этого. ';
?>


Depressive

Дак что, уже можно безопасно обновиться?

S.T.A.L.K.E.R.

Цитата: digger® от 17 Май 2017, 12:56:13Нормальный перевод есть в актуальных языковых файлах, причем уже давно.
Тогда ещё не полный перевод.В марте же его вообще небыло.
Код
	Дополнительную информацию по данному вопросу можно найти в интернете.';
$helptxt['image_proxy_enabled'] = 'Whether to enable the image proxy';
$helptxt['image_proxy_secret'] = 'Keep this a secret, protects your forum from hotlinking images. Change it in order to render current hotlinked images useless';
$helptxt['image_proxy_maxsize'] = 'Maximum image size that the image proxy will cache: bigger images will be not be cached. Cached images are stored in your SMF cache folder, so make sure you have enough free space.';

GeorG

Цитата: digger® от 17 Май 2017, 12:56:13Нормальный перевод есть в актуальных языковых файлах, причем уже давно.
Стоит уточнить, что лучше перевод целиком не накатывать тому, у кого уже имеются установленные моды, чтобы не затереть их перевод, а брать из него только нужные строчки, и вставлять в свои файлы русификации.

Цитата: Depressive от 17 Май 2017, 13:02:00Дак что, уже можно безопасно обновиться?
Можно, но вопрос будет ли после этого форум нормально работать (и будет ли вообще), всё ещё открыт.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

gorbi

Так а чего ждать? 2.0.15? Модов под под 2.0.14 или чего-то ещё? На офф. форуме ни слова про работу над 2.0.14. Всё вокруг версии php

GeorG

Помните патч 2.0.12, он тоже был не совсем юзабельный, но у многих тем не менее отлично работал (например, у тех у кого не было портала, или других модов завязанных на кэшировании), и все ждали патч 2.0.13, который показал себя как стабильная версия. Возможно тут будет так же история. Я например, буду себе ставить патч 2.0.14, я исправлю все моды которые работают с ним нестабильно, естественно кто может сам все править, то лучше ему обновляться, или заказывать обновление у тех, кто это ему может сделать, или ждать следующий патч, где исправят все косяки того, что есть сейчас (возможно все и не исправят, из-за несовместимости).
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

gorbi

Надо принять за реальность кризис с разработкой SMF и поэтому вряд ли стоит ждать быстрого обновления, а может и вообще обновления. На мой взгляд нужно брать то, что есть и пытаться довести до ума.

GeorG

Кризис, а когда его не было (люди за бесплатно сидят там, кто-то пришёл в команду, кто-то ушёл)? Вроде как шли обновления, так они и идут по мере их законченности, не всегда они подходят для конечных пользователей, но так то больше зависит от того, какие моды у них стоят и какое серверное ПО, но то уже не от разработчика зависит.
Их заботит только то, чтобы на чистом форуме всё работало без ошибок, с заявленными ими параметрами северного ПО.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

gorbi

Цитата: GeorG от 17 Май 2017, 15:15:19Кризис, а когда его не было (люди за бесплатно сидят там, кто-то пришёл в команду, кто-то ушёл)? Вроде как шли обновления, так они и идут по мере их законченности, не всегда они подходят для конечных пользователей, но так то больше зависит от того, какие моды у них стоят и какое серверное ПО, но то уже не от разработчика зависит.
Их заботит только то, чтобы на чистом форуме всё работало без ошибок, с заявленными ими параметрами северного ПО.
Не соглашусь с вами. Большинство предыдущий патчей касалось закрытия обнаруженных дыр в безопасности и по сути не были плановыми. Обнаружилась дыра, закрыли.

2.0.14, в основном, касается SSL и здесь были давно озвучены Гуглом и Эпплом временные рамки, которые не были выполнены.

GeorG

Они и не хотели делать поддержку SSL и php7 для версии форума 2.0, это они подались по большей мере просьбам комьюнити, так сказать их уломали сделать такую поддержку, они её сделали и она в принципе работает без всяких проблем на чистом форуме. Проблемы у пользователей с модами и их ПО.
Т.е, нужно обновлять моды и серверное оборудование, но это уже не к разработчику форума.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

digger®

Цитата: GeorG от 17 Май 2017, 15:28:29Они и не хотели делать поддержку SSL и php7 для версии форума 2.0, это они подались по большей мере просьбам комьюнити, так сказать их уломали
Ну как это "уломали"? PHP 7.0 это в наши дни актуальная версия ПО, а не какая-то rocket science. SSL тоже в обед сто лет, хотя с ним проблем не было и на старых версиях, а image proxy это уже шашечки. После выхода SMF 2.1, SMF 2.0 никуда не денется и будет еще несколько лет поддерживаться, а вот PHP 5.6 уже три месяца как снята с активной поддержки и будет получать только обновления безопасности до конца 2018 года. Так что, было бы странно, если бы SMF 2.0 не получил поддержку PHP 7.

gorbi

Да и не вышла ещё 2.1 и не известно, когда выйдет.

S.T.A.L.K.E.R.

Ну а мне кажется что на этом обновлении можно уже и остановиться.Вроде как всё что надо пока есть.Я вообще не думал обновляться.

GeorG

Цитата: digger® от 17 Май 2017, 16:02:42Так что, было бы странно, если бы SMF 2.0 не получил поддержку PHP 7.
Ну собственно потому что странно, и потому что неизвестно когда выйдет 2.1 (как написал gorbi), потому и сделали поддержку, изначально ведь она не планировалась.

На оф.сайте, Arantor предполагает что не ранее 2020 выйдет.
Верстка тем по шаблону, их доработка/переработка, переделка тем с версии smf 1.1 на smf 2.0. Примеры работ - insidestyle.ru
Установка модов (заточка под ваш форум); Моды под заказ; Обновление форума; Правильный перенос; Удаление/лечение вирусов; Устранения ошибок.
Обращаться в ЛС
Мой форум
Модуль анти-спама CleanTalk, сам пользуюсь
Сервера которыми сам пользуюсь - cadedic.ru

S.T.A.L.K.E.R.

Цитата: GeorG от 17 Май 2017, 17:09:25На оф.сайте, Arantor говорит что не ранее 2020 выйдет.
Если только RC1 тогда поверю.

Wodan

Добрый день!
Ставил на два форума:
- первая установка вчера на форум с рнр5.3 и темой ресселлер - плучил 500 ошибку, восстановился и отложил, так как хостер обещал обновить рнр только на след. неделе
- вторая установка на классическую тему и минимум модов + рнр5.4 - стал нормально

Что интересует: есть настройка размер хранилища - я дал 10 ГБ, но интересует, что будет, когда хранилище будет заполнено и стоит ли в кроне прописать очистку кеша изображений, например, раз в неделю.

digger®

Цитата: Wodan от 17 Май 2017, 17:33:24Что интересует: есть настройка размер хранилища - я дал 10 ГБ, но интересует, что будет, когда хранилище будет заполнено и стоит ли в кроне прописать очистку кеша изображений, например, раз в неделю.
Что за настройка размера хранилища? У прокси есть только настройка максимального размера файла, который будет кэшироваться.

gorbi

vbgamer45 утверждает, что в первоначальный патч были внесены изменения в течении нескольких часов. Очень жаль, нет визуальных инструментов отслеживания изменений.

S.T.A.L.K.E.R.

Цитата: gorbi от 17 Май 2017, 19:24:37vbgamer45 утверждает, что в первоначальный патч были внесены изменения в течении нескольких часов. Очень жаль, нет визуальных инструментов отслеживания изменений.
Тогда мы все скачивали уже измененный патч.
Все может быть.

ALINA

Так все таки ,кто как собирается выходить из положения ?

digger®

Цитата: gorbi от 17 Май 2017, 19:24:37vbgamer45 утверждает, что в первоначальный патч были внесены изменения в течении нескольких часов. Очень жаль, нет визуальных инструментов отслеживания изменений.
Вот разница между 2.0.13 и первым вариантом 2.0.14 https://github.com/realdigger/SMF-2.0-RU/commit/e2facf9a4a65eac69f2160ccc6e78a6e75bfd222
Вот разница между первым вариантом 2.0.14 и текущим https://github.com/realdigger/SMF-2.0-RU/commit/19afa84cedd03d54e966c18f0a6523219a1013bc


ALINA



gorbi

Цитата: digger® от 17 Май 2017, 20:28:03Вот разница между 2.0.13 и первым вариантом 2.0.14 https://github.com/realdigger/SMF-2.0-RU/commit/e2facf9a4a65eac69f2160ccc6e78a6e75bfd222
Вот разница между первым вариантом 2.0.14 и текущим https://github.com/realdigger/SMF-2.0-RU/commit/19afa84cedd03d54e966c18f0a6523219a1013bc
Спасибо! Очень наглядно!

S.T.A.L.K.E.R.

Цитата: digger® от 17 Май 2017, 20:28:03Вот разница между первым вариантом 2.0.14 и текущим https://github.com/realdigger/SMF-2.0-RU/commit/19afa84cedd03d54e966c18f0a6523219a1013bc
Я это качнул в 7 утра понедельника,и там это изменение уже было получается.
И тем не менее народ пишет что у многих проксирование толком не работает.Выходит что ещё не поправили,а если и поправили то в паблике ещё нет.


gorbi

Цитата: S.T.A.L.K.E.R. от 17 Май 2017, 22:41:33народ пишет что у многих проксирование толком не работает
Обещают исправить в следующем релизе.

S.T.A.L.K.E.R.

Цитата: gorbi от 18 Май 2017, 09:21:53Обещают исправить в следующем релизе.
Ждем 2.0.15 :)

Snow_Irbis

Изменил я версию php на 5.6 что была совместимость с обновлением, а совместно с этой версией php у хостера не работает XCache (так как типа XCache поддерживает только тип php интерпрeтатора для сайта "php как apache", а что бы изменить версию php надо изменять настройки сайта на "php как cgi"), а других доступных акселераторов нет :facepalm:  Поэтому возник такой вопрос, сильно ли повлияет отсутствие кеширования если посещаемость от 100 до 300 хостов в день? Или клевать мозг саппорту что бы реализовывал доступность XCache/искать другого хостера?