First Post on Every Page — отображение первого сообщения на каждой странице темы

Автор Bugo, 28 Ноябрь 2009, 23:35:53

« назад - далее »

0 Пользователей и 1 гость просматривают эту тему.

Bugo

Оригинальный мод версии 1.1 (поддерживает SMF 1.1.6, 1.1.7, 1.1.8, 1.1.10, 2.0 Beta 4, 2.0 RC1, 2.0 RC1.2) качаем здесь

Доработанный мной вариант (только для RC2!), с русификацией — во вложении.
Проверено на работоспособность на чистой версии RC2.

bober

для версий 1.1,* этот мод действовал на те темы которые были закреплены а не на все.
Ваш мод действует на все темы без исключения. Можно поправить?
Мод ставил на 2-ку, все ок, кроме выше перечисленного

Bugo

Цитата: bober от 29 Ноябрь 2009, 16:22:31
для версий 1.1,* этот мод действовал на те темы которые были закреплены а не на все.
Ваш мод действует на все темы без исключения. Можно поправить?
Мод ставил на 2-ку, все ок, кроме выше перечисленного
При установке мода под списком производимых изменений найдите раскрывающийся список «Установить в другие темы оформления» и посмотрите, какие изменения предлагает сделать мод. Сделайте их вручную (понадобится чуть подправить файл Display.template.php).

Nemo000


bober

стал хорошо, только что то не закрепляет пост. Или где то включать нужно??

Bugo

Цитата: bober от 02 Декабрь 2009, 09:19:44
стал хорошо, только что то не закрепляет пост. Или где то включать нужно??
Админка — Темы и сообщения — Настройка сообщений — Включить показ первого сообщения на каждой странице (поставить галочку).

bober


Bugo

Цитата: bober от 02 Декабрь 2009, 14:52:29
у меня нет такого там
Значит, как-то не так установился. В общем, не заморачивайтесь, а попробуйте этот мод — http://www.simplemachines.ru/index.php?topic=1915.0. Он эстетичней смотрится и настроек никаких не надо (кнопка Закрепить/Открепить в каждом первом посте темы) :)

bober


Bugo

Цитата: bober от 02 Декабрь 2009, 20:45:18
у меня 2,0 RC2
По все видимости этот только нормальный http://www.simplemachines.ru/index.php?topic=1915.msg59453#msg59453
Я эту версию и имел в виду. Нормально работает, никаких настроек в админке не требует.

bober

Цитата: Bugo от 02 Декабрь 2009, 21:08:47
Я эту версию и имел в виду. Нормально работает, никаких настроек в админке не требует.
проблема решалась.
Удалил мод (правда при удалении ошибки писало)
Скачал по новой и снова установил. Теперь работает как надо.

ku7mich

First Post on Every Page 1.4 (2011-4-28)
SMF 2.0 RC5
Интересный момент, при установке в ./Themes/core/Display.template.php пытается найти:
Цитировать</h5> <div class="smalltext">« <strong>', !empty($message['counter']) ? $txt['reply_noun'] . ' #' . $message['counter'] : '', ' ', $txt['on'], ':</strong> ', $message['time'], ' »</div> <div id="msg_', $message['id'], '_quick_mod"></div>
и заменить на
Цитировать</h5> <div class="smalltext">« <strong>', !($message['id'] == $context['topic_first_message']) ? $txt['reply_noun'] . ' #' . $message['counter'] : '', ' ', $txt['on'], ':</strong> ', $message['time'], ' »</div> <div id="msg_', $message['id'], '_quick_mod"></div>
Между тем в файле установки мода и Display.template.php написано &_#_171_;(это кавычки, без нижних подчёркиваний). Дело в настройках апача?
"Как странно – когда исчезает темнота, перестаешь видеть свет!" (С. Лукьяненко)