ошибка при установке SMF 2.0.11

Автор Aura, 18 Сентябрь 2016, 11:23:11

« назад - далее »

0 Пользователей и 1 гость просматривают эту тему.

Aura

при установке форума SMF 2.0.11 в подраздел сайта, при открытии страницы site.ru/forum пишет ошибку:
"Программа установки не обнаружила поддержку баз данных в PHP. Пожалуйста, спросите вашего хостера, скомпилирован ли PHP с поддержкой баз данных и загружены ли необходимые модули. "

что нужно исправить в базе данных, чтоб началась нормальная установка?

valdnieks

Установка MySQL:

apt-get install mysql-server mysql-client

PHP:

apt-get install php5 libapache2-mod-php5

Дополнительно можно установить и некоторые другие пакеты для работы PHP с различными модулями. Для этого выполним команду:

apt-get install php5-mysql php5-curl php5-gd php5-intl php-pear php5-imagick php5-imap php5-mcrypt php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl
Registered Linux user #325316
Последняя версия SMF: SMF 2.0.15
Версия GD: bundled (2.1.0 compatible)
Версия MySQL: 5.5.23
PHP: 5.6.30
Версия Web сервера: Apache/2.4.25 (Win64) PHP/5.6.30

kak2z

Цитата: Aura от 18 Сентябрь 2016, 11:23:11при установке форума SMF 2.0.11 в подраздел сайта, при открытии страницы site.ru/forum пишет ошибку:
"Программа установки не обнаружила поддержку баз данных в PHP. Пожалуйста, спросите вашего хостера, скомпилирован ли PHP с поддержкой баз данных и загружены ли необходимые модули. "

что нужно исправить в базе данных, чтоб началась нормальная установка?
Вы куда ставите?? на хостинг?? или еще куда то??
Если нужно что то исправить, обновить, переставить, настроить, сделать форум заново - пишите в ЛС)

digger®

Цитата: Aura от 18 Сентябрь 2016, 11:23:11при установке форума SMF 2.0.11 в подраздел сайта, при открытии страницы site.ru/forum пишет ошибку:
"Программа установки не обнаружила поддержку баз данных в PHP. Пожалуйста, спросите вашего хостера, скомпилирован ли PHP с поддержкой баз данных и загружены ли необходимые модули. "

что нужно исправить в базе данных, чтоб началась нормальная установка?
Если php7 то нужно переключить на php5

Aura

Цитата: kak2z от 18 Сентябрь 2016, 12:37:19Вы куда ставите?? на хостинг?? или еще куда то??
да, на хостинг
там поддержка MSQLi

kak2z

Цитата: Aura от 19 Сентябрь 2016, 08:08:30да, на хостинг
там поддержка MSQLi
Там выше по поводу пхп написали. Вы проверили?
Если нужно что то исправить, обновить, переставить, настроить, сделать форум заново - пишите в ЛС)


Aura

Цитата: kak2z от 19 Сентябрь 2016, 08:32:47Там выше по поводу пхп написали. Вы проверили?
нет, это мне нужно техподдержке хостинга направлять, самостоятельно не проверю, поскольку не программист

в общем понятно, просто не поддерживается этот форум на данный момент

S.T.A.L.K.E.R.

Цитата: Aura от 19 Сентябрь 2016, 20:29:05просто не поддерживается этот форум на данный момент
У хостера может поддерживаться всё,это не проблема сейчас.
Ну или практически всё,уж mysql это точно.

Солярис

А с какой настройкой лучше устанавливать форум с MySQL или MSOLi?