Открывается через раз (Свежеустановленный) - Решено!

Автор Akrobs, 21 Март 2016, 16:52:31

« назад - далее »

0 Пользователей и 1 гость просматривают эту тему.

Akrobs

21 Март 2016, 16:52:31 Последнее редактирование: 21 Март 2016, 19:08:09 от Akrobs
Доброго дня.
Имеется свой сервер:
Cent OS 6.7
Панель управления хостингом  Sentora (бывшая Zpanel)
Apache 2.2.15
MySQL 5.5.48
PHP 5.5.32 (Zend Engine v2.5.0, Zend OPcache v7.0.6-dev, Suhosin v0.9.37.1)

Суть проблемы: Только что установленный форум будь-то версии 2.0.11 или 2.1 бета, открывается через раз, т.е. надо несколько раз обновить сраницу, чтобы сгенерировался контент.
Причем, если залогиниться под админом, то все работает с первого раза.
Подозреваю, что где-то надо искать проблему в конфигах сервера, возможно что-то мешает или чего-то не хватает.
Буду благодарен за подсказку.

kak2z

Цитата: Akrobs от 21 Март 2016, 16:52:31Доброго дня.
Имеется свой сервер:
Cent OS 6.7
Панель управления хостингом  Sentora (бывшая Zpanel)
Apache 2.2.15
MySQL 5.5.48
PHP 5.5.32 (Zend Engine v2.5.0, Zend OPcache v7.0.6-dev, Suhosin v0.9.37.1)

Суть проблемы: Только что установленный форум будь-то версии 2.0.11 или 2.1 бета, открывается через раз, т.е. надо несколько раз обновить сраницу, чтобы сгенирировался контент.
Причем, если залогиниться под админом, то все работает с первого раза.
Подозреваю, что где-то надо искать проблему в конфигах сервера, возможно что-то мешает или чего-то не хватает.
Буду благодарен за подсказку.
а логи что говорят?  думаю надо смотреть апач и пхп логи..

Сервер отдает вот такое
Код
HTTP/1.1 200 OK
Date: Mon, 21 Mar 2016 17:01:05 GMT
Server: Apache
Set-Cookie: PHPSESSID=0ts53q715hgpm24jp6ka5ft7a7; path=/
Expires: Mon, 26 Jul 1997 05:00:00 GMT
Cache-Control: private
Pragma: no-cache
X-Frame-Options: SAMEORIGIN
X-XSS-Protection: 1
X-Content-Type-Options: nosniff
Last-Modified: Mon, 21 Mar 2016 17:01:05 GMT

а иногда добавляет еще одну строку вниз
Код
Content-Type: text/html; charset=UTF-8
Если нужно что то исправить, обновить, переставить, настроить, сделать форум заново - пишите в ЛС)

Akrobs

Вот что генерит, когда пусто
Код
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv="Content-Type" content="text/html; charset=utf-8"></HEAD>
<BODY></BODY></HTML>
Благодарю за быстрый ответ.

kak2z

Цитата: Akrobs от 21 Март 2016, 17:05:20Вот что генерит, когда пусто
Код
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv="Content-Type" content="text/html; charset=utf-8"></HEAD>
<BODY></BODY></HTML>
Благодарю за быстрый ответ.

да я видел что генерит...
логи можно увидеть только на сервере...
и кеширование попробуйте вырубить.. пробовали?
Если нужно что то исправить, обновить, переставить, настроить, сделать форум заново - пишите в ЛС)

Akrobs

21 Март 2016, 17:18:36 #4 Последнее редактирование: 21 Март 2016, 18:11:57 от Akrobs
Пока залез на сервер, смотрю логи...
В логах Apache только такое:
Код
[Sun Mar 20 03:14:01 2016] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 20 03:14:01 2016] [notice] Digest: done
[Sun Mar 20 03:14:01 2016] [notice] Apache/2.2.15 (Unix) mod_ssl/2.2.15 OpenSSL/1.0.1e-fips configured -- resuming normal operations
Кеширование отключать непробовал. Сейчас проверю.
Upd. Кеширование отключил - без изменений.


Нашел в логах такие ошибки:
Код
PHP Warning:  ob_start(): output handler 'ob_gzhandler' conflicts with 'zlib output compression' in /public_html/miroved_org/forum/install.php on line 177

Код
PHP Notice:  ob_start(): failed to create buffer in /public_html/miroved_org/forum/install.php on line 177

S.T.A.L.K.E.R.

http://www.simplemachines.org/community/index.php?topic=75963.0
Админка,настройка сервера снять галочку  Использовать сжатие трафика и сохранить

Akrobs

21 Март 2016, 18:26:15 #6 Последнее редактирование: 21 Март 2016, 18:46:40 от Akrobs
Цитата: Stalker от 21 Март 2016, 18:20:37http://www.simplemachines.org/community/index.php?topic=75963.0
Админка,настройка сервера снять галочку  Использовать сжатие трафика и сохранить

Спасибо сейчас попробую.


Нашел на просторах вот такое решение Туц
Оказывается я не один с такой проблей с панелью Sentora.

Upd. Попробовал, галочки нету, а если поставишь и сохраняешь - исчезает.

Upd.2 Закомментировал код, что по линку выше и все заработало!

Огромная благодарность всем откликнувшимся!