Регистрация новых пользователей

Автор rival28, 04 Август 2006, 13:20:01

« назад - далее »

0 Пользователи и 1 Гость просматривают эту тему.

rival28

Установлено
Joomla! 1.0.10 RE Стабильная версия [ Sundown ]
SMF 1.1.RC2
бридж Simple Machines  1.1.5  

При добавлении нового пользователя проходит процедура и по окончании чистый экран. После этого пользователь может войти в форум, добавляем второго и получаем ошибку  предложение обратиться к администратору.

Текст ошибки в логах SMF
ЦитироватьОшибка базы данных: Duplicate entry '16777215' for key 1
Файл: /home/paraglid/public_html/Community/Sources/Subs-Members.php
Строка: 780

Почему новому пользователю даётся ID 16777215 ? Этот ID присваивается всем новым пользователям. База со старыми пользователями была перенесена вручную через phpMyadmin со старого форума. Атрибут auto_increment  на поле ID_MEMBER  установлен

ЗЫ присутствие  или отсутствие моста не играет никакой роли, сейчас снес бридж и ошибка осталась
Опубликовано: 04 Августа 2006, 01:55:45
зря сюда перенес, я ж говорю - присутствие интеграции никак не влияет на ошибку

Сейчас нет никакой интеграции и ошибка есть. Возможно в базе ключик какойто криво перенёсся, только я не могу понять какой.

Mavn

Администрирование - Обслуживание форума - Пересчет статистики, проверка форума на ошибки сделай и посмотри как будет дальше работать форум
SimpleMachines Russian Community Team
п.1 Пройду курсы гадалок для определения исходного кода по скриншоту.

п.2 У вас нет желания читать правила раздела, у меня нет желания одобрять темы, которые не соответствуют этим правилам.

rival28

раз десять сделал :) ошибка осталась. новый пользователь стабильно получает нереальный ID, который не меняется, всего в базе около 360 пользователей.


я читаю форум этот, всё что могли тут насоветовать, всё перепробовал. вот только как убрать ключик Uniqe пока не додумался, ночью это вычитал, голова уже не соображала
Опубликовано: 04 Августа 2006, 13:37:08
в профиле у меня сайт указан - если не влом попробуй пройти регистрацию, может я чего то очевидного не вижу

Mavn

в общем базу нужно смотреть так сказать ничего не могу
SimpleMachines Russian Community Team
п.1 Пройду курсы гадалок для определения исходного кода по скриншоту.

п.2 У вас нет желания читать правила раздела, у меня нет желания одобрять темы, которые не соответствуют этим правилам.

rival28

посмотрел базу

в закладке Operations нашол это значение, сриншот прилагаю. У кого какие мысли? Замена этого значения на любое другое не помогает - в окне запроса всё равно появляется "16777215"

Опубликовано: 04 Августа 2006, 16:16:46
c auto_increment вроде разобрался, теперь осталось разобраться почему после регистрации чистый экран - никаких сообщений приглашений а чистый и пустой html

Mavn

в общем проблема в том что были внесены изменения в результате которых у тебя сейчас проблемы.
1. Перезалей файлы форума
2. почини бд и тогда у тебя будет все работать нормально
SimpleMachines Russian Community Team
п.1 Пройду курсы гадалок для определения исходного кода по скриншоту.

п.2 У вас нет желания читать правила раздела, у меня нет желания одобрять темы, которые не соответствуют этим правилам.

rival28

ну фвто_инремент вручную, через sql запрос из окошка свосстановил, вот тока чистый экран побороть осталось, версии и размеры файлов сравнил вроде всё совпадает. Но еще посмотрю.