код при инсталяции smf в мамбу

Автор iiy, 09 Апрель 2006, 12:21:53

« назад - далее »

0 Пользователи и 1 Гость просматривают эту тему.

iiy

Не уверен что вопрос для этой рубрики, перенесите если это не сюда

при инсталяции форума в мамбу предлагается вставить два блока кодов в файл
вот первый

<?php
global $sc, $context, $settings;

if (!defined('SMF')){
require ("administrator/components/com_smf/config.smf.php");
require ($smf_path."/SSI.php");
}

$sc = &$context['session_id'];
$_SESSION['USER_AGENT'] = $_SERVER['HTTP_USER_AGENT'];

mysql_select_db($mosConfig_db);

echo '
<script language="JavaScript" type="text/javascript" src="', $settings['default_theme_url'], '/script.js?beta4"></script>
<script language="JavaScript" type="text/javascript"><!-- // --><![CDATA[
var smf_theme_url = "', $settings['theme_url'], '";
var smf_images_url = "', $settings['images_url'], '";
var smf_scripturl = "', $scripturl, '";
var smf_session_id = "', $context['session_id'], '";
// ]]></script>';

echo '
<link rel="stylesheet" type="text/css" href="', $settings['theme_url'], '/style.css?rc1" />
<link rel="stylesheet" type="text/css" href="', $settings['default_theme_url'], '/print.css?beta4" media="print" />
<link rel="help" href="', $scripturl, '?action=help" target="_blank" />
<link rel="search" href="' . $scripturl . '?action=search" />
<link rel="contents" href="', $scripturl, '" />';
?>

и еще один, маленький одной строкой, не буду приводить, хотя интересно для чего он


ВОПРОС:

после вставки кода (первой части) сам сайт меняет дизайн, фон становится другим и отступ появляется по краям
я убрал часть кода, дизайн вернулся, но что убрал и на что это повлияет не знаю  :-\
проясните, если кто знает и не лень  ;)

Спасибо заранее!

Lord Gaos

Цитата: iiy от 09 Апрель 2006, 12:21:53
echo '
<link rel="stylesheet" type="text/css" href="', $settings['theme_url'], '/style.css?rc1" />
<link rel="stylesheet" type="text/css" href="', $settings['default_theme_url'], '/print.css?beta4" media="print" />
<link rel="help" href="', $scripturl, '?action=help" target="_blank" />
<link rel="search" href="' . $scripturl . '?action=search" />
<link rel="contents" href="', $scripturl, '" />';
?>
после вставки кода (первой части) сам сайт меняет дизайн, фон становится другим и отступ появляется по краям
я убрал часть кода, дизайн вернулся, но что убрал и на что это повлияет не знаю  :-\
проясните, если кто знает и не лень  ;)
У меня сегодня такая же проблема была, убрал как раз ту часть кода которая в цитировании. Насколько я понял она отвечает за таблицы стилей. Только зачем оно вообще надо не понятно. Тем более, что работает таким вот странным образом.