Joomla 1.0.8+SMF 1.1RC2+Joomla-SMF 1.1 login problem

Автор GuNeR, 31 Март 2006, 13:49:53

« назад - далее »

0 Пользователи и 1 Гость просматривают эту тему.

GuNeR

Установил с нуля
Joomla 1.0.8
SMF 1.1RC2
Joomla-SMF 1.1 от www.joomlahacks.com
все прошло отлично, но после активации нового пользователя на форуме, он не может залогиниться на форум, получает сообщение о том что поля имя пользователя и пароль не заполнены.
Если этого пользователя добавить в пользователи Joomla то сообщение перестает появляться, а пользователя перенапаравляет на главную страницу, залогинивание не происходит.

В чем дело? :(

liman

04 Апрель 2006, 22:51:23 #1 Последнее редактирование: 04 Апрель 2006, 22:59:38 от liman
код надо один в  компонент моста вставить , найдёш здесь на инглише
http://www.simplemachines.org/community/index.php?topic=25718.msg351330#msg351330

или на этом форуме
http://www.simplemachines.ru/index.php?topic=220.0

GuNeR

там речь идет о мосте от симплмашинеров, а я использую джумлхацкеровский...

liman

А этот у меня вообще ни каким боком не стал... так что помоч не смогу :(

Дело в том, что функцию логин в 1.0.8 изменили, скачай новый мост может там это учли уже

GuNeR

я поставил самый последний мост спецально отфикшеный под 1.0.8.... так вот глюк остался...
приходится пользователй отправлять после активации на форуме на глстраницу чтобы оттуда логинились 1 раз.. после чего система проводитс синхронизацию и пользователь может свободно логиниться на форуме

ROCKfor

У меня итегрированная мамба с SMF 1.1. RC2 тем же мостиком. Все тоже самое. Логиниться первый раз на сайте еще куда ни шло.

Мне интересно как была решена проблема с именем пользователя. Юзер при регистрации на сайте нормально заполняет ФИО, потом эти ФИО отображаются на форуме. Он меняет отображаемое имя (ФИО) на ник и теперь неизвестно какое у него было ФИО. Запретить менять отображаемое имя тоже не хочется, т.к. ФИО на форуме не смотрится никак. Может кто знает как сделать так чтобы имя пользователя и отображаемое имя было одним и тем же, а ФИО в последствии он вообще менять не мог?

liman

У меня нормально работает только когда юзверов регистрирую через форму SMF и не пользуюсь врапером.

GuNeR

Цитата: ROCKfor от 06 Апрель 2006, 17:00:14
У меня итегрированная мамба с SMF 1.1. RC2 тем же мостиком. Все тоже самое. Логиниться первый раз на сайте еще куда ни шло.

Мне интересно как была решена проблема с именем пользователя. Юзер при регистрации на сайте нормально заполняет ФИО, потом эти ФИО отображаются на форуме. Он меняет отображаемое имя (ФИО) на ник и теперь неизвестно какое у него было ФИО. Запретить менять отображаемое имя тоже не хочется, т.к. ФИО на форуме не смотрится никак. Может кто знает как сделать так чтобы имя пользователя и отображаемое имя было одним и тем же, а ФИО в последствии он вообще менять не мог?
Нужно лезть в код и добавлять еще одно поле "ФИО" в профиль, т.е. писать модуль...

mukca

вопрос
как сделать автоматическую синхронизацию ююзверей?? (ну тип зарегался на форуме а на портале его нет. и на оборот. приходиться вручную)
использую:
Joomla 1.0.10
SMF 1.1RC2
Joomla-SMF_1_1_3_bridge

GuNeR

нужно скачать последний мост от джумла хацкеров, там решена эта проблема :)

удачи :)

mukca

это откуда?? можно названия не пересерать/?
http://www.joomlahacks.com/ оно/?
так от туда нечег оне качаетсья

GuNeR

да оттуда, чтобы начало качаться необходимо зарегестрироваться у них на форуме

mukca

спасиб помогло :)
(правда мин 20 вспоминал регистрацию свою у них)