Проблема с последними сообщениями форума?

Автор jagger, 23 Май 2007, 10:42:21

« назад - далее »

0 Пользователи и 1 Гость просматривают эту тему.

jagger

Стоит джумла 1.0.12 и смф 1.1.2, модуль последних сообщений mod_latestsmf. В самом смф, если перейти вручную в тему к определенному сообщению ссылка будет:
_http://site.ru/forum/topic,155.msg947#msg947
Если с главной форума, последнее сообщение имеют ссылку вида:
_http://site.ru/index.php?option=com_smf&Itemid=75&topic=155.msg948#new
Если переходить по ссылке из модуля последних сообщений главной, то ссылка будет:
_http://site.ru/forum/index.php?topic=155.msg947;topicseen#new
Если очистить кеш браузера, то ссылка будет:
_http://site.ru/forum/index.php/topic,155.msg947/topicseen.html#new

Теперь собственно вопрос: почему одно и тоже сообщение представлено четыремя разными ссылками и как этого избежать???

p.s. В модуле ссылка получается путем $post['href'].

jagger

может не очень понятно было объяснено... посмотрите тогда данную ситуацию на _http://rlab.ru
если у кого идеи появятся - пишите.

Avdenago

да понятно. ситуация вполне естественная. вот только сходу решения не видно...

jagger


Avdenago

ну потому что никто не застрахован...  вы же используете бридж и скорее всего SEO-url...  вот. при таком наборе всякие непонятки естественны... 

jagger

Вот еще вариант описания данной проблемы:
Если site.ru - первый сайт, куда заходишь после открытия браузера, то ссылки кривые, http://site.ru/forum/index.php?topic=155.msg947;topicseen#new. Если уже хоть куда-то заходил перед посещением сайта, то всё ок, ссылки http://site.ru/forum/index.php/topic,155.msg947/topicseen.html#new. Причём если зайти на форум сразу, а не на сайт - то всё ок, даже если заходишь как на первую страницу после запуска, все ссылки нормальные. Функции для вывода урла в форуме и в модуле последних сообщений используются теже. Мегастранный глюк. Может кто сталкивался уже...